Opened 13 years ago

Closed 6 years ago

#506 closed defect (wontfix)

v.out.ascii reserved words problem when exporting columns from the attribute table

Reported by: dylan Owned by: grass-dev@…
Priority: minor Milestone: 6.5.0
Component: Vector Version: svn-develbranch6
Keywords: v.out.ascii, dbf_driver Cc:
CPU: Unspecified Platform: Unspecified

Description

v.out.ascii is giving a segfault when a column is supplied to the 'columns' argument. Example with the spearfish database:

v.out.ascii in=bugsites format=point columns=str1

[...]

D4/5: eval_node node_type = 2
D4/5:     right = 2
D4/5:     right_dval = 1.000000
D4/5:     operator = 11
D4/5: condition = 0
D2/5: load_table_head(): tab = 2, /home/dylan/grass/spearfish60/PERMANENT/dbf//bugsites.dbf
Segmentation fault

I have tried this with several vector files using the DBF backend, all with the same result. Using the MySQL backend v.out.ascii appears to work fine.

Change History (4)

comment:1 Changed 13 years ago by hamish

works for me.

/home/dylan/grass/spearfish60/PERMANENT/dbf//bugsites.dbf

I don't think it makes a difference, but bugsites.dbf ?

Hamish

comment:2 Changed 13 years ago by dylan

Keywords: dbf_driver added
Priority: majorminor

Updates: with a recent SVN update, I see that v.out.ascii columns=... works as expected, except when the column name may be an SQL reserved word.

This does not work:

v.out.ascii pits columns=Comment

This works:

v.out.ascii pits columns=Max_PDOP

I wonder if there is something that can be done about this...

comment:3 Changed 9 years ago by hamish

Component: DefaultVector
Keywords: v.out.ascii dbf_driverv.out.ascii, dbf_driver
Summary: v.out.ascii segfault when exporting columns from the attribute tablev.out.ascii reserved words problem when exporting columns from the attribute table

comment:4 Changed 6 years ago by dylan

Resolution: wontfix
Status: newclosed

No longer relevant.

Note: See TracTickets for help on using tickets.