Opened 13 years ago

Closed 12 years ago

#484 closed defect (fixed)

Cannot reload maps to wxnviz

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 6.5.0
Component: wxGUI Version: svn-develbranch6
Keywords: wxnviz Cc: landa.martin@…
CPU: OSX/Intel Platform: MacOSX

Description

This has always been a problem, but I haven't reported it because there were other issues to fix in the new wxnviz. But now that it is getting so much better otherwise, I guess it's time to get a track ticket on this.

I open maps and switch to 3D mode and everything looks and works fine. I exit 3D mode successfully. No errors are reported during 3D mode or on exiting.

I try to go back to 3D mode with the same maps and same display and the 3D interface does not respond or does not respond correctly, and 3D maps are not displayed or not displayed correctly (e.g., displayed without color and only while moving the puck; then the map disappears). I get error messages in the terminal and console. I'm pretty sure that this is linked to an error I reported earlier with a failure to load any maps 2nd time around (track #445). Here are the detailed error messages.

Terminal message

<Error>: CGContextRestoreGState: invalid context

Layer manager console message

Nviz:Raster map <elevation.10m@PERMANENT> unloaded successfully Nviz:Loading failed Nviz:Loading raster map <elevation.10m@PERMANENT> failed Nviz:Loading failed Nviz:Loading raster map <elevation.10m@PERMANENT> failed Traceback (most recent call last):

File "/Applications/Grass?/GRASS-6.5.app/Contents/MacOS/etc

/wxpython/gui_modules/nviz_mapdisp.py", line 971, in UpdateMapObjProperties?

id = datasurface?object?id? KeyError? : 'object' Traceback (most recent call last):

File "/Applications/Grass?/GRASS-6.5.app/Contents/MacOS/etc

/wxpython/gui_modules/nviz_mapdisp.py", line 971, in UpdateMapObjProperties?

id = datasurface?object?id? KeyError? : 'object' Traceback (most recent call last):

File "/Applications/Grass?/GRASS-6.5.app/Contents/MacOS/etc

/wxpython/gui_modules/nviz_mapdisp.py", line 971, in UpdateMapObjProperties?

id = datasurface?object?id? KeyError? : 'object' Traceback (most recent call last):

File "/Applications/Grass?/GRASS-6.5.app/Contents/MacOS/etc

/wxpython/gui_modules/nviz_mapdisp.py", line 971, in UpdateMapObjProperties?

id = datasurface?object?id? KeyError? : 'object'

Change History (3)

comment:1 Changed 13 years ago by cmbarton

I want to note that this is still a problem, at least on the Mac.

A second time displaying a map in 3D in a session produces the following error:

Nviz:Loading raster map <elevation.10m@PERMANENT> failed Traceback (most recent call last):

File "/Applications/Grass?/GRASS-6.5.app/Contents/MacOS/etc

/wxpython/gui_modules/nviz_mapdisp.py", line 961, in UpdateMapObjProperties?

id = datasurface?object?id? KeyError? : 'object'

The problem is caused by the raster not loading to 3D a 2nd time during a session.

Michael

comment:2 Changed 12 years ago by cmbarton

This issue is fixed in GRASS 6.4 and 6.5 but is still broken in GRASS 7.

Michael

comment:3 Changed 12 years ago by cmbarton

Resolution: fixed
Status: newclosed

This seems to run fine in all versions on my Mac now. Since I initially reported it, submitted an initial fix, and no one else has reported a problem, I'll close this now.

Michael

Note: See TracTickets for help on using tickets.