Opened 11 years ago

Closed 11 years ago

#445 closed defect (fixed)

grass_nviz.LoadSurface not returning id when called a 2nd time

Reported by: cmbarton Owned by: martinl
Priority: major Milestone: 7.0.0
Component: wxGUI Version: svn-develbranch6
Keywords: Cc: grass-dev@…
CPU: OSX/Intel Platform: MacOSX

Description

This item may fix a number of things.

If you start wxnviz and display a map, close wxnviz, restart nviz...

The 2nd time you start wxnnviz...

id = self.nvizClass.LoadSurface?(str(layer.name), None, None)

in nviz_mapdisplay.py is not returning the id of the map. It returns only -1. It's got the name right in both cases. But it returns an id value the first time it is run, but not subsequently.

This is at line 477 of nviz_mapdisp.py. I'm not sure, but it looks like a SWIG call in grass_nviz.py.

Because this does not return an id value, a lot of other things begin to bomb.

Change History (3)

comment:1 Changed 11 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

I am unable to reproduce it, probably I am doing something.

  1. add raster layer elev_state_500m
  2. display in 2D mode
  3. display in 3D mode -> id 110658
  4. quit 3D mode
  5. switch back to 3D mode -> id 110658

Martin

comment:2 Changed 11 years ago by cmbarton

Milestone: 6.4.07.0.0

This is fixed in 6.4 and 6.5, but still broken in 7. I'm changing the milestone so that it is no longer a problem for the GRASS 6 series. We probably just need to port the fix (I don't remember what it was) from 6.5 to 7.

Michael

comment:3 Changed 11 years ago by cmbarton

Resolution: fixed
Status: assignedclosed

This now seems completely fixed in 7.0 too. No one else has talked about it and it works for me. I'm closing it.

Michael

Note: See TracTickets for help on using tickets.