Opened 11 years ago

Closed 11 years ago

#444 closed defect (worksforme)

wxGui gives error with xy location

Reported by: paoloC Owned by: grass-dev@…
Priority: major Milestone: 7.0.0
Component: wxGUI Version: svn-trunk
Keywords: Cc: martinl
CPU: x86-32 Platform: Linux

Description

wxGui turn back this error when starts with a simple xy location:

Error in Commad execution Execution failed:'g.region -u -g -p -c'.

Traceback (most recent call last):

File "/usr/local/grass-7.0.svn/etc/wxpython/wxgui.py", line 1520, in <module>

sys.exit(main())

File "/usr/local/grass-7.0.svn/etc/wxpython/wxgui.py", line 1513, in main

app = GMApp(workspaceFile)

File "/usr/local/grass-7.0.svn/etc/wxpython/wxgui.py", line 1435, in init

wx.App.init(self, False)

File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7912, in init

self._BootstrapApp()

File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 7487, in _BootstrapApp

return _core_.PyAppBootstrapApp(*args, kwargs)

File "/usr/local/grass-7.0.svn/etc/wxpython/wxgui.py", line 1451, in OnInit?

workspace = self.workspaceFile)

File "/usr/local/grass-7.0.svn/etc/wxpython/wxgui.py", line 175, in init

self.NewDisplay?(show=False)

File "/usr/local/grass-7.0.svn/etc/wxpython/wxgui.py", line 1116, in NewDisplay?

auimgr=self._auimgr, showMapDisplay=show)

File "/usr/local/grass-7.0.svn/etc/wxpython/gui_modules/wxgui_utils.py", line 106, in init

Map=self.Map, auimgr=self.auimgr)

File "/usr/local/grass-7.0.svn/etc/wxpython/gui_modules/mapdisp.py", line 245, in init

self.MapWindow?.ZoomHistory?(self.Map.regionn?,

KeyError?: 'n'

No errors with the same location with grass6.4.svn.

Attachments (1)

simplexy.tar.gz (15.2 KB) - added by paoloC 11 years ago.
simple xy location

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by paoloC

Attachment: simplexy.tar.gz added

simple xy location

comment:1 Changed 11 years ago by martinl

Cc: martinl added

I cannot reproduce the error. Do you have still problem with recent trunk?

Martin

comment:2 Changed 11 years ago by cmbarton

Resolution: worksforme
Status: newclosed

I cannot reproduce this on my Mac either. This bug is old and does not seem to be a problem any longer on either Linux or Mac. I'm closing with worksforme.

Michael

Note: See TracTickets for help on using tickets.