Opened 3 months ago

Closed 3 weeks ago

#3885 closed defect (fixed)

wxGUI no longer shows start image

Reported by: neteler Owned by: grass-dev@…
Priority: normal Milestone: 7.8.1
Component: wxGUI Version: git-releasebranch78
Keywords: g.gui Cc:
CPU: Unspecified Platform: Unspecified

Description (last modified by neteler)

When starting g.gui in G78dev only a kind of empty frame is shown (really, some graphic memory garbage of the window behind if present) while it works ok in master.

System description:

System Info                                                                     
GRASS version: 7.8.dev                                                          
Code revision: a50165153                                                        
Build date: 2019-08-12                                                          
Build platform: x86_64-pc-linux-gnu                                             
GDAL: 2.3.2                                                                     
PROJ.4: 5.2.0                                                                   
GEOS: 3.7.1                                                                     
SQLite: 3.26.0                                                                  
Python: 3.7.4                                                                   
wxPython: 4.0.4                                                                 
Platform: Linux-5.2.8-200.fc30.x86_64-x86_64-with-fedora-30-Thirty              

Change History (9)

comment:1 in reply to:  description Changed 3 months ago by mmetz

Replying to neteler:

When starting g.gui in G78dev only a kind of empty frame is shown (really, some graphic memory garbage of the window behind if present) while it works ok in master.

Not reproducible on Fedora 30, please make distclean, check git status, then recompile.

comment:2 Changed 3 months ago by veroandreo

I have the same issue reported in a freshly re-compiled grass-dev in Fedora 30 (I use make distclean).

I get this in the terminal when opening GRASS:

/home/veroandreo/software/grass77-dev/dist.x86_64-pc-linux-gnu/gui/wxpython/wxgui.py:101: DeprecationWarning: Yield() is deprecated
  wx.Yield()

Might that be related?

Last edited 3 months ago by veroandreo (previous) (diff)

comment:3 Changed 3 months ago by veroandreo

If I start in text mode, and then call GUI with g.gui, then the start image displays normally and with the same message as described above... so, no idea

comment:4 Changed 3 months ago by neteler

At startup (using relbr78), I see these error messages:

/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/gui/wxpython/wxgui.py:101: DeprecationWarning: Yield() is deprecated
  wx.Yield()
16:09:21: Debug: Adding duplicate image handler for 'Windows bitmap file'
16:09:21: Debug: Adding duplicate image handler for 'Windows bitmap file'

comment:5 in reply to:  4 ; Changed 3 months ago by annakrat

I can't reproduce on Ubuntu. Are you sure that it works in master? If yes, it shouldn't be that hard to figure out the specific commit causing it.

Replying to neteler:

At startup (using relbr78), I see these error messages:

/home/mneteler/software/grass78_git/dist.x86_64-pc-linux-gnu/gui/wxpython/wxgui.py:101: DeprecationWarning: Yield() is deprecated
  wx.Yield()
16:09:21: Debug: Adding duplicate image handler for 'Windows bitmap file'
16:09:21: Debug: Adding duplicate image handler for 'Windows bitmap file'

It's not error, just warnings and debug, I think I get these too, so they don't have to mean anything.

comment:6 Changed 3 months ago by neteler

Description: modified (diff)

comment:7 in reply to:  5 Changed 3 months ago by neteler

Replying to annakrat:

I can't reproduce on Ubuntu. Are you sure that it works in master? If yes, it shouldn't be that hard to figure out the specific commit causing it.

After reboot it works in both master and relbranch78.

It seems to be a fuzzy problem :(

comment:8 Changed 2 months ago by neteler

Milestone: 7.8.07.8.1

Ticket retargeted after milestone closed

comment:9 Changed 3 weeks ago by neteler

Resolution: fixed
Status: newclosed
Version: git-releasebranch78

Fixed in master and release_branch_7_8. Closing

Note: See TracTickets for help on using tickets.