Opened 17 months ago

Closed 14 months ago

Last modified 14 months ago

#3591 closed defect (fixed)

r.import does not recognize selected file

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 7.4.2
Component: wxGUI Version: svn-trunk
Keywords: r.import Cc:
CPU: Unspecified Platform: Unspecified

Description

r.import will not recognize files selected and showing in the list of raster layers. No matter what, it returns this message:

"No layer selected. Operation canceled"

Maybe related to issue solved in https://trac.osgeo.org/grass/ticket/3570. I don't know if this is a Mac specific issue, a wxPython 4 related issue, or something more general.

In GRASS 7.5 trunk, compiled 12 June 2018

Attachments (4)

g_gui_r_import_linux.jpg (66.4 KB) - added by neteler 15 months ago.
Screenshot of raster import via g.gui
r-import_bug.jpg (244.6 KB) - added by cmbarton 15 months ago.
screenshot of r.import bug
v.import_error_mac.png (526.6 KB) - added by baharmon 14 months ago.
Error message for v.import on Mac
r.import_error_mac.png (467.0 KB) - added by baharmon 14 months ago.
Error message for r.import on Mac

Download all attachments as: .zip

Change History (17)

comment:1 Changed 16 months ago by mmetz

Milestone: 7.6.0

Is this a problem of the GUI of r.import or of r.import itself, i.e. does the error appear when run on the CLI or when run in the GUI?

comment:2 Changed 16 months ago by cmbarton

It's the GUI wrapper.

comment:3 Changed 15 months ago by neteler

I made a quick test: NC sample dataset, g.gui >> File >> Import raster map >> Simplified ... (r.import).

No problem identified. See screenshot

Changed 15 months ago by neteler

Attachment: g_gui_r_import_linux.jpg added

Screenshot of raster import via g.gui

Changed 15 months ago by cmbarton

Attachment: r-import_bug.jpg added

screenshot of r.import bug

comment:4 Changed 15 months ago by cmbarton

I've added a screenshot that shows what happens when I press the "import" button

comment:5 Changed 14 months ago by baharmon

v.import on Mac also has this bug in the GUI. r.import and v.import both work fine in the command line on Mac. Tested on GRASS 7.4.1 on Mac.

comment:6 Changed 14 months ago by cmbarton

What I reported is for the GUI

Changed 14 months ago by baharmon

Attachment: v.import_error_mac.png added

Error message for v.import on Mac

Changed 14 months ago by baharmon

Attachment: r.import_error_mac.png added

Error message for r.import on Mac

comment:7 in reply to:  6 Changed 14 months ago by baharmon

Replying to cmbarton:

What I reported is for the GUI

Right, I am just adding that v.import has the same error. Maybe that should go in a separate ticket. Regarding the command line, I just wanted to clarify that both commands work and the issue is with the GUI.

comment:8 Changed 14 months ago by annakrat

Try r73472. #3629 is related, needs testing too.

comment:9 Changed 14 months ago by cmbarton

These are fixed in trunk but do not seem fixed in 7.4 RB.

comment:10 Changed 14 months ago by annakrat

Backported to 76 and 74, please test and close if solved.

comment:11 Changed 14 months ago by cmbarton

Thanks much. I’ll test tomorrow

comment:12 Changed 14 months ago by cmbarton

Resolution: fixed
Status: newclosed

This is fixed in v. 7.4 on up. Closing

comment:13 Changed 14 months ago by martinl

Milestone: 7.6.07.4.2
Note: See TracTickets for help on using tickets.