Opened 5 years ago

Closed 3 years ago

#3372 closed defect (duplicate)

Export map display as vector file from GUI

Reported by: baharmon Owned by: grass-dev@…
Priority: normal Milestone: 7.2.4
Component: Default Version: svn-trunk
Keywords: d.out.file, cairo, svg, gui Cc:
CPU: Unspecified Platform: Unspecified

Description

Currently there are only a few format options - png, jpg, bmp, gif, tif - for exporting the map display with d.out.file using the GUI (rather than scripting). It would be very useful to be able to export the map display in a vector file format. This would improve the quality of maps in publications (with scalable linework and scalable text in legends) and allow much easier editing. Maps exported in a vector file format such as svg could then be edited in Inkscape for example. Ideally the export would include both raster and vector data with the legend and labels saved as vectors.

Perhaps this could be done by using the cairo driver for d.out.file since cairo supports pdf, ps, and svg. d.out.file seems to have had more options in GRASS 6.4 including png, ppm, tif, geotiff, jpg, bmp, ps, eps, svg, pdf, and a flag for cairo.

Change History (3)

comment:1 by neteler, 5 years ago

Please see also #3033

comment:2 by martinl, 4 years ago

Milestone: 7.2.4

comment:3 by mlennert, 3 years ago

Resolution: duplicate
Status: newclosed

I actually consider this a duplicate of #3033, so closing.

Note: See TracTickets for help on using tickets.