Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#3041 closed defect (duplicate)

Grass Nviz crashes

Reported by: virtuale71 Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: wxGUI Version: 7.0.4
Keywords: m.nviz.image Cc:
CPU: x86-64 Platform: MSWindows 7

Description

I am using Grass 7.04 standalone. I have made a 3d view of dem raster. How can I have a high resolution image file of it to work with Photoshop? It seems that the only tool to have it is Nviz but it always crashes and the genereated Tiff file that is empty.

If you select a Ppm file it generates a few Kbites file; I can't open it, but its size can't match with an high resolution image.

Some experiments have been done with previous Grass 6xxx and Grass 7.04 on windows 10. Result is the same. In older 6xxx Grass version a popup states that there is a memory issue. We have tried to cut the raster smaller and smaller but the problem wasn't solved.

| Type of Map: raster Number of Categories: 0 | | Data Type: FCELL | | Rows: 2610 | | Columns: 3711 | | Total Cells: 9685710 | | Projection: Monte Mario / Italy zone 1 | | N: 4186765.97697097 S: 4181546.28599823 Res: 1.9998816 | | E: 2344938.10330853 W: 2337516.69538672 Res: 1.99984045 | | Range of data: min = 175.59 max = 672.84

And the error log: APPCRASH m.nviz.image.exe 7.0.0.0

application Timestamp: 5725e1e3 Module with errors name: libgrass_ogsf.7.0.4.dll Version of module with errors: 0.0.0.0 Module with error Timestamp: 5725df0e Exception code: c0000094 Exception Offset: 000000000002c080 SO version: 6.1.7601.2.1.0.256.48 ID local settings: 1040 Other infos 1: f010 Extra infos 2: f010b8bf1a53840503aacbf5539daf48 Extra infos 3: cb08 Extra infos 4: cb08b57330503ec68eb2a7f62401ed8b

Comand log: (Mon May 23 17:34:34 2016) m.nviz.image --overwrite --quiet elevation_map=Gibellina_Vecchia@Ale height=3886 zexag=1.5 focus=1000,1000,1000 output=C:\Users\Ale\12122.tif format=tif size=640,480 (Mon May 23 17:34:38 2016) Comando terminato (3 sec)

Would the verbose output be better?

Change History (4)

comment:1 Changed 3 years ago by annakrat

Component: Tcl/Tk NVIZwxGUI
Keywords: m.nviz.image added
Milestone: 7.0.5
Resolution: duplicate
Status: newclosed

Duplicate of #2114. It should still work in the GUI using 3D view, so you can try it there. Or on a different platform.

comment:2 in reply to:  description Changed 3 years ago by neteler

Replying to virtuale71:

I am using Grass 7.04 standalone. I have made a 3d view of dem raster. How can I have a high resolution image file of it to work with Photoshop?

If you want a 2D map, then you can also use d.out.file.

Do you want a perspective view?

comment:3 Changed 3 years ago by virtuale71

Yes, I need a perspective view, like the ones you can have on the display. The problem is that you can only have a low resolution image of it, more or less of the resolution of a screenshot.

Can this depend upon my system? I have a PC, does somebody knows if there is the same problem on Mac?

comment:4 in reply to:  3 Changed 3 years ago by wenzeslaus

Replying to virtuale71:

Can this depend upon my system? I have a PC, does somebody knows if there is the same problem on Mac?

m.nviz.image works well on Linux and Mac (except for an error at the end of rendering on Mac where it reports some error but renders the image). wxGUI 3D view should give high resolution image when your screen is high resolution regardless of platform (you still need enough memory for the data, 64bit version is helpful in this (64bit GRASS GIS is standard on Linux and it is new on MS Windows, but note that MS Windows depending on the version artificially limit memory usage in different ways)).

Note: See TracTickets for help on using tickets.