Opened 3 years ago

Closed 3 years ago

#3039 closed defect (duplicate)

"Analyze map" not working with GRASS 7.0.4 (OSX - homebrew)

Reported by: guano Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: wxGUI Version: 7.0.4
Keywords: histogram, matplotlib Cc:
CPU: x86-64 Platform: MacOSX

Description (last modified by martinl)

Running GRASS 7.0.4 on OSX (El Capitan) installed via Homebrew.

The "Analyze map" tools in Map Display are not working. The old ones do work (profile, d.histogram), but Scatter Plot, Histogram don't.

The tools that need python/matplotlib are not working with the following error message:

Traceback (most recent call last):
  File "/usr/local/Cellar/grass-70/7.0.4/grass-7.0.4/gui/wxp
ython/mapdisp/frame.py", line 1066, in OnHistogramPyPlot

win = HistogramPlotFrame(parent = self, rasterList = raster)
  File "/usr/local/Cellar/grass-70/7.0.4/grass-7.0.4/gui/wxp
ython/wxplot/histogram.py", line 39, in __init__

BasePlotFrame.__init__(self, parent, size = size, **kwargs)
  File "/usr/local/Cellar/grass-70/7.0.4/grass-7.0.4/gui/wxp
ython/wxplot/base.py", line 88, in __init__

self.client = plot.PlotCanvas(self)
  File "/usr/local/lib/python2.7/site-
packages/wx-3.0-osx_cocoa/wx/lib/plot.py", line 598, in
__init__

self.HandCursor = wx.Cursor(Hand.GetImage())
  File "/usr/local/lib/python2.7/site-
packages/wx-3.0-osx_cocoa/wx/_gdi.py", line 1502, in
__init__

_gdi_.Cursor_swiginit(self,_gdi_.new_Cursor(*args,
**kwargs))
TypeError
:
Required argument 'type' (pos 2) not found

The same happens when calling them form the contextual menu (right-click).

Change History (3)

comment:1 Changed 3 years ago by martinl

Description: modified (diff)

comment:2 Changed 3 years ago by cmbarton

This is probably due to a known bug in wxPython 3.x. I've documented this and a workaround in ticket:

https://trac.osgeo.org/grass/ticket/2813

Michael

comment:3 Changed 3 years ago by annakrat

Resolution: duplicate
Status: newclosed

Duplicate of #2558.

Note: See TracTickets for help on using tickets.