Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2813 closed defect (duplicate)

wxplot tools fails with wxPython 3

Reported by: martinl Owned by: grass-dev@…
Priority: blocker Milestone: 7.2.0
Component: wxGUI Version: unspecified
Keywords: wxplot, wxpython 3 Cc:
CPU: x86-64 Platform: Linux

Description

wxGUI tools like Histogram or Profile fails with wxPython 3

OnHistogram

win = HistogramPlotFrame(parent = self, rasterList =
rasterList)
  File "/opt/src/grass_trunk/dist.x86_64-unknown-linux-
gnu/gui/wxpython/wxplot/histogram.py", line 39, in __init__

BasePlotFrame.__init__(self, parent, size = size, **kwargs)
  File "/opt/src/grass_trunk/dist.x86_64-unknown-linux-
gnu/gui/wxpython/wxplot/base.py", line 88, in __init__

self.client = plot.PlotCanvas(self)
  File "/usr/lib/python2.7/dist-
packages/wx-3.0-gtk2/wx/lib/plot.py", line 598, in __init__

self.HandCursor = wx.Cursor(Hand.GetImage())
  File "/usr/lib/python2.7/dist-
packages/wx-3.0-gtk2/wx/_gdi.py", line 1510, in __init__

_gdi_.Cursor_swiginit(self,_gdi_.new_Cursor(*args,
**kwargs))
TypeError
:
Required argument 'type' (pos 2) not found

Change History (7)

comment:1 Changed 4 years ago by neteler

Please add the precise package version as well.

comment:2 Changed 4 years ago by mlennert

This seems a duplicate of #2558.

comment:3 in reply to:  1 ; Changed 4 years ago by neteler

Replying to neteler:

Please add the precise package version as well.

I tried here: Using wxPython-3.0.2.0-7.fc23.x86_64 no such issue, works fine.

comment:4 in reply to:  3 ; Changed 4 years ago by mlennert

Resolution: duplicate
Status: newclosed

Replying to neteler:

Replying to neteler:

Please add the precise package version as well.

I tried here: Using wxPython-3.0.2.0-7.fc23.x86_64 no such issue, works fine.

Yes, but here you can read that this fedora version contains specific patches for that issue:

* Sun Jan 04 2015 Scott Talbert <swt@techie.net> - 3.0.2.0-2 - Added patches for fixing crash in GetXWindow() and wx.lib.plot bugs

So IIUC, if people have 3.0.2 without those patches it won't work.

I am closing this ticket now, as it is a duplicate of #2558, so that we don't have two parallel discussions of the issue.

comment:5 in reply to:  4 Changed 4 years ago by martinl

Replying to mlennert:

> * Sun Jan 04 2015 Scott Talbert <swt@techie.net> - 3.0.2.0-2 - Added patches for fixing crash in GetXWindow() and wx.lib.plot bugs

confirmed, I have

'3.0.2.0'

comment:6 Changed 4 years ago by cmbarton

Here is the error I get on the Mac for the profile tool (similar to histogram tool). wxPython 3.2.0 and system Python 2.7. OS X 10.10.5

Traceback (most recent call last):
  File "/Applications/GRASS-7.1_64bit.app/Contents/MacOS/gui
/wxpython/mapdisp/frame.py", line 1074, in OnProfile

self.Profile(rasters=rasters)
  File "/Applications/GRASS-7.1_64bit.app/Contents/MacOS/gui
/wxpython/mapdisp/frame.py", line 1082, in Profile

controller=self.profileController)
  File "/Applications/GRASS-7.1_64bit.app/Contents/MacOS/gui
/wxpython/wxplot/profile.py", line 52, in __init__

BasePlotFrame.__init__(self, parent=parent, size=size,
**kwargs)
  File "/Applications/GRASS-7.1_64bit.app/Contents/MacOS/gui
/wxpython/wxplot/base.py", line 88, in __init__

self.client = plot.PlotCanvas(self)
  File "/Applications/GRASS-7.1_64bit.app/Contents/MacOS/etc
/python/wx/lib/plot.py", line 598, in __init__

comment:7 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

Note: See TracTickets for help on using tickets.