Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2997 closed defect (fixed)

python editor refuses to run script with UI after closing GUI dialog

Reported by: martinl Owned by: grass-dev@…
Priority: normal Milestone: 7.2.0
Component: wxGUI Version: unspecified
Keywords: python, editor, pyedit Cc:
CPU: Unspecified Platform: Unspecified

Description (last modified by martinl)

Steps to reproduce:

  1. open simple python editor
  2. load GRASS module example
  3. run -> GUI is shown
  4. close dialog
  5. run -> nothing happens

Reason: self.running is still True

Change History (5)

comment:1 Changed 4 years ago by martinl

Description: modified (diff)

comment:2 Changed 4 years ago by martinl

Summary: python editor refuses to run script with UI after closing multiple timespython editor refuses to run script with UI after closing GUI dialog

comment:3 Changed 4 years ago by neteler

Milestone: 7.1.07.2.0

Milestone renamed

comment:4 Changed 4 years ago by wenzeslaus

Resolution: fixed
Status: newclosed

In 68396:

pyedit: do not use onDone because it is not executed when GUI is invoked (fixes #2997)

Now you can run again even if it is already running
which is the same behavior as for normal module calls.

It also uses the same temporary file once it was created
to avoid the need to delete it all the time. It is deleted
when file is actually saved.

Also remove suppression of the GUI interface because we
actually want to get GUI (the parameter does not work, r68395).

comment:5 Changed 4 years ago by wenzeslaus

Keywords: pyedit added
Note: See TracTickets for help on using tickets.