Opened 11 years ago

Closed 7 years ago

#271 closed defect (worksforme)

some tabs of command dialogs are too narrow

Reported by: msieczka Owned by: grass-dev@…
Priority: minor Milestone: 6.4.0
Component: wxGUI Version: svn-develbranch6
Keywords: Cc:
CPU: All Platform: All

Description

Some tabs of command dialogs are too narrow. Examples:

"Advanced" of v.buffer

"Optional" of r.out.gdal

"Bounds" of g.region

Attachments (2)

v-buffer.png (10.6 KB) - added by martinl 11 years ago.
v.buffer seems OK
dalog_too_narrow.png (13.7 KB) - added by msieczka 11 years ago.
no it's not

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by martinl

Attachment: v-buffer.png added

v.buffer seems OK

comment:1 Changed 11 years ago by martinl

Seems OK here... see the attached screenshot.

comment:2 in reply to:  1 ; Changed 11 years ago by msieczka

Replying to martinl:

Seems OK here... see the attached screenshot.

I don't mean the "Required" tab of v.buffer but "Advanced" tab. For me it's not OK (too narrow).

comment:3 in reply to:  2 ; Changed 11 years ago by martinl

Priority: majortrivial
Type: defectenhancement

Replying to msieczka:

Replying to martinl:

Seems OK here... see the attached screenshot.

I don't mean the "Required" tab of v.buffer but "Advanced" tab. For me it's not OK (too narrow).

Well, it's just a style of notebook tabs which is used by default. For me this style is OK, even I would prefer less 'fancy' one. If you want we can add new option to GUI preferences, but it doesn't seems to me useful.

comment:4 in reply to:  3 ; Changed 11 years ago by msieczka

Replying to martinl:

Replying to msieczka:

Replying to martinl:

Seems OK here... see the attached screenshot.

I don't mean the "Required" tab of v.buffer but "Advanced" tab. For me it's not OK (too narrow).

Well, it's just a style of notebook tabs which is used by default. For me this style is OK, even I would prefer less 'fancy' one. If you want we can add new option to GUI preferences, but it doesn't seems to me useful.

We are talking about two different things.

I mean that the v.buffer wxGUI dialog is to narrow to accomodate the "Advanced" tab contents. See the attached screendump.

Same for "Optional" of r.out.gdal, "Bounds" of g.region and more.

Changed 11 years ago by msieczka

Attachment: dalog_too_narrow.png added

no it's not

comment:5 in reply to:  4 ; Changed 11 years ago by martinl

Priority: trivialminor
Type: enhancementdefect

Replying to msieczka:

We are talking about two different things.

OK, now I got the point;-)

I mean that the v.buffer wxGUI dialog is to narrow to accomodate the "Advanced" tab contents. See the attached screendump.

Same for "Optional" of r.out.gdal, "Bounds" of g.region and more.

I cannot reproduce this behaviour on my machines (Debian GNU/Linux unstable + WindowMaker?, Redhat + Gnome). I made some changes in menuform module (r33204). Helps?

comment:6 in reply to:  5 Changed 11 years ago by msieczka

Replying to martinl:

I cannot reproduce this behaviour on my machines (Debian GNU/Linux unstable + WindowMaker?, Redhat + Gnome). I made some changes in menuform module (r33204). Helps?

Nope. Stil I have to extend the window 2 pixels to the right to get rid of the horizontal slider.

Debian testing amd64 with Gnome.

comment:7 Changed 10 years ago by cmbarton

I cannot reproduce this on my Mac with the current 6.5 svn. Is it fixed on other platforms too?

Michael

comment:8 Changed 7 years ago by neteler

Resolution: worksforme
Status: newclosed

Looks like solved. Closing.

Note: See TracTickets for help on using tickets.