Opened 5 years ago

Closed 5 years ago

#2602 closed defect (fixed)

GUI preferences dialog fails to open

Reported by: marisn Owned by: grass-dev@…
Priority: normal Milestone: 7.0.1
Component: wxGUI Version: 7.0.0
Keywords: Cc:
CPU: Unspecified Platform: MSWindows XP

Description

When choosing a "settings" -> "preferences", only an error is printed in the command line. Tested with 7.0.0 on XP and Vista

Traceback (most recent call last):
  File "C:\Program Files\GRASS GIS
7.0.0\gui\wxpython\lmgr\frame.py", line 1537, in
OnPreferences

dlg = PreferencesDialog(parent=self, giface=self._giface)
  File "C:\Program Files\GRASS GIS
7.0.0\gui\wxpython\gui_core\preferences.py", line 231, in
__init__

self._createGeneralPage(self.notebook)
  File "C:\Program Files\GRASS GIS
7.0.0\gui\wxpython\gui_core\preferences.py", line 282, in
_createGeneralPage

label = _("Hide '%s' tab (requires GUI restart)") %
_("Search module"),
TypeError
:
not all arguments converted during string formatting

Change History (4)

comment:1 Changed 5 years ago by martinl

Milestone: 7.0.1

comment:2 Changed 5 years ago by annakrat

Works for me with English locale on Windows 8. Is locale the problem?

comment:3 Changed 5 years ago by marisn

It is caused by a faulty translation to Latvian language (shame on me). Issue is fixed in trunk with r64789

Leaving open, as r64789 needs to be backported to release branch.

comment:4 in reply to:  3 Changed 5 years ago by neteler

Resolution: fixed
Status: newclosed

Replying to marisn:

Leaving open, as r64789 needs to be backported to release branch.

Backported, closing.

Note: See TracTickets for help on using tickets.