Opened 6 years ago

Closed 5 years ago

#2601 closed defect (worksforme)

Raster query fails with unicode error

Reported by: marisn Owned by: grass-dev@…
Priority: normal Milestone: 7.0.2
Component: wxGUI Version: 7.0.0
Keywords: query Cc:
CPU: Unspecified Platform: MSWindows XP

Description

Tested on a fresh 7.0.0 install on XP and Vista.

Steps to reproduce - use attribute query tool on any raster map.

Traceback (most recent call last):
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\lib\mixins\treemixin.py",
line 450, in OnItemExpanding

self.RefreshChildrenRecursively(event.GetItem())
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\lib\mixins\treemixin.py",
line 375, in RefreshChildrenRecursively

self.RefreshItemRecursively(child, childIndex)
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\lib\mixins\treemixin.py",
line 382, in RefreshItemRecursively

item = self.DoRefreshItem(item, itemIndex, hasChildren)
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\lib\mixins\treemixin.py",
line 393, in DoRefreshItem

self.RefreshItemText(item, index)
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\lib\mixins\treemixin.py",
line 403, in RefreshItemText

self.__refreshAttribute(item, index, 'ItemText')
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\lib\mixins\treemixin.py",
line 464, in __refreshAttribute

return getattr(self, 'Set%s'%attribute)(item, value, *args)
  File "C:\Program Files\GRASS GIS 7.0.0\Python27\lib\site-
packages\wx-2.8-msw-unicode\wx\gizmos.py", line 647, in
SetItemText

return _gizmos.TreeListCtrl_SetItemText(*args, **kwargs)
  File "C:\Program Files\GRASS GIS
7.0.0\Python27\lib\encodings\cp1257.py", line 15, in decode

return codecs.charmap_decode(input,errors,decoding_table)
UnicodeDecodeError
:
'charmap' codec can't decode byte 0x81 in position 3:
character maps to <undefined>

Using same coordinates for r.what works just fine:

(Fri Feb 27 10:13:13 2015)                                                      
r.what map=geology@PERMANENT coordinates=594416.666667,4925361.11111            
594416.666667|4925361.11111||9
(Fri Feb 27 10:13:14 2015) Command finished (0 sec)

Change History (3)

comment:1 Changed 6 years ago by annakrat

Keywords: query added
Milestone: 7.0.1

I can't reproduce it. I tried on Windows 8. Any idea why it doesn't work on your side?

comment:2 Changed 5 years ago by neteler

Milestone: 7.0.17.0.2

Ticket retargeted after 7.0.1 milestone closed

comment:3 Changed 5 years ago by martinl

Resolution: worksforme
Status: newclosed

No feedback in last 6 months. Closing.

Note: See TracTickets for help on using tickets.