Opened 7 years ago

Closed 7 years ago

#2596 closed defect (duplicate)

v.rast.stats not working on GRASS 6.4.4

Reported by: micha Owned by: grass-dev@…
Priority: major Milestone: 6.4.5
Component: Shell Scripts Version: 6.4.4
Keywords: v.rast.stats Cc:
CPU: Unspecified Platform: Linux

Description

Using v.rast.stats in GRASS 6.4.4 I am finding two problems.

The new script uses 'BEGIN TRANSACTION', but if the backend database is still dbf, transactions are not supported, and the process fails.

If I switch to sqlite tables, the process runs, but I am getting NULL values in all the univariate stats columns.

I tried to replace the v.rast.stats shell script with the script from the older 6.4.2 tarball, and it works fine.

Regards, Micha

Change History (1)

comment:1 by neteler, 7 years ago

Keywords: v.rast.stats added
Milestone: 6.4.5
Resolution: duplicate
Status: newclosed

This is a duplicate of #2457 which I hopefully solved.

You may try the updated script from here: https://svn.osgeo.org/grass/grass/branches/releasebranch_6_4/scripts/v.rast.stats/v.rast.stats

It will be part of the upcoming GRASS GIS 6.4.5.

Note: See TracTickets for help on using tickets.