Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#2561 closed defect (fixed)

7.0.0 beta & RC tarballs contain precompiled Python objects

Reported by: Bas Couwenberg Owned by: grass-dev@…
Priority: blocker Milestone: 7.0.0
Component: Packaging Version: svn-releasebranch70
Keywords: python, pyc Cc: sebastic@…
CPU: Unspecified Platform: All

Description

The release tarballs contain precompiled Python objects, which lintian warns about during the Debian package build process.

The attached patch adds the removal of .pyc files to the release instructions.

The following precompiled Python objects are included the tarball for 7.0.0RC1:

-rw-r--r-- neteler/gis   72068 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/gselect.pyc
-rw-r--r-- neteler/gis   22687 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/mapdisp.pyc
-rw-r--r-- neteler/gis   23359 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/goutput.pyc
-rw-r--r-- neteler/gis   12800 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/toolbars.pyc
-rw-r--r-- neteler/gis   10124 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/query.pyc
-rw-r--r-- neteler/gis   82334 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/dialogs.pyc
-rw-r--r-- neteler/gis     390 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/gui_core/__init__.pyc
-rw-r--r-- neteler/gis   25748 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/ghelp.pyc
-rw-r--r-- neteler/gis   65035 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/forms.pyc
-rw-r--r-- neteler/gis   16904 2014-03-27 20:29 grass-7.0.0RC1/gui/wxpython/gui_core/prompt.pyc
-rw-r--r-- neteler/gis   16358 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/simplelmgr.pyc
-rw-r--r-- neteler/gis   51452 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/preferences.pyc
-rw-r--r-- neteler/gis    8107 2013-12-26 23:06 grass-7.0.0RC1/gui/wxpython/gui_core/pystc.pyc
-rw-r--r-- neteler/gis    8027 2014-01-02 14:43 grass-7.0.0RC1/gui/wxpython/gui_core/menu.pyc
-rw-r--r-- neteler/gis    9600 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/gui_core/treeview.pyc
-rw-r--r-- neteler/gis   50047 2014-04-06 15:56 grass-7.0.0RC1/gui/wxpython/gui_core/widgets.pyc
-rw-r--r-- neteler/gis   17563 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/location_wizard/dialogs.pyc
-rw-r--r-- neteler/gis     208 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/location_wizard/__init__.pyc
-rw-r--r-- neteler/gis    2256 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/location_wizard/base.pyc
-rw-r--r-- neteler/gis   62335 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/location_wizard/wizard.pyc
-rw-r--r-- neteler/gis   19610 2014-03-27 20:28 grass-7.0.0RC1/gui/wxpython/core/gconsole.pyc
-rw-r--r-- neteler/gis   10985 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/core/ws.pyc
-rw-r--r-- neteler/gis   42542 2013-12-30 13:56 grass-7.0.0RC1/gui/wxpython/core/workspace.pyc
-rw-r--r-- neteler/gis     380 2013-04-21 23:37 grass-7.0.0RC1/gui/wxpython/core/__init__.pyc
-rw-r--r-- neteler/gis   22875 2014-02-24 00:10 grass-7.0.0RC1/gui/wxpython/core/settings.pyc
-rw-r--r-- neteler/gis    7658 2014-03-27 20:28 grass-7.0.0RC1/gui/wxpython/core/treemodel.pyc
-rw-r--r-- neteler/gis    8517 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/core/menutree.pyc
-rw-r--r-- neteler/gis    5611 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/core/units.pyc
-rw-r--r-- neteler/gis   13864 2013-12-30 13:56 grass-7.0.0RC1/gui/wxpython/core/layerlist.pyc
-rw-r--r-- neteler/gis    5814 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/core/globalvar.pyc
-rw-r--r-- neteler/gis   10788 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/core/giface.pyc
-rw-r--r-- neteler/gis   39722 2014-03-03 17:44 grass-7.0.0RC1/gui/wxpython/core/render.pyc
-rw-r--r-- neteler/gis   24615 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/core/toolboxes.pyc
-rw-r--r-- neteler/gis   32212 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/core/utils.pyc
-rw-r--r-- neteler/gis    2215 2013-04-21 23:37 grass-7.0.0RC1/gui/wxpython/core/debug.pyc
-rw-r--r-- neteler/gis   21267 2013-10-03 00:22 grass-7.0.0RC1/gui/wxpython/core/gcmd.pyc
-rw-r--r-- neteler/gis   15421 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/modules/histogram.pyc
-rw-r--r-- neteler/gis     251 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/modules/__init__.pyc
-rw-r--r-- neteler/gis   56038 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/modules/colorrules.pyc
-rw-r--r-- neteler/gis   15572 2013-11-24 22:39 grass-7.0.0RC1/gui/wxpython/mapwin/decorations.pyc
-rw-r--r-- neteler/gis     241 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/mapwin/__init__.pyc
-rw-r--r-- neteler/gis   14233 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/mapwin/base.pyc
-rw-r--r-- neteler/gis   12046 2014-03-03 17:44 grass-7.0.0RC1/gui/wxpython/mapwin/graphics.pyc
-rw-r--r-- neteler/gis   56405 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/mapwin/buffered.pyc
-rw-r--r-- neteler/gis   13369 2014-01-13 00:35 grass-7.0.0RC1/gui/wxpython/mapwin/analysis.pyc
-rw-r--r-- neteler/gis    5774 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/mapdisp/gprint.pyc
-rw-r--r-- neteler/gis   41459 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/mapdisp/frame.pyc
-rw-r--r-- neteler/gis    9593 2014-01-13 00:35 grass-7.0.0RC1/gui/wxpython/mapdisp/toolbars.pyc
-rw-r--r-- neteler/gis     272 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/mapdisp/__init__.pyc
-rw-r--r-- neteler/gis   41962 2013-11-03 01:25 grass-7.0.0RC1/gui/wxpython/mapdisp/statusbar.pyc
-rw-r--r-- neteler/gis    8180 2014-02-04 07:30 grass-7.0.0RC1/gui/wxpython/nviz/animation.pyc
-rw-r--r-- neteler/gis  157263 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/nviz/tools.pyc
-rw-r--r-- neteler/gis    9642 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/nviz/workspace.pyc
-rw-r--r-- neteler/gis     273 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/nviz/__init__.pyc
-rw-r--r-- neteler/gis   75656 2014-03-27 20:29 grass-7.0.0RC1/gui/wxpython/nviz/mapwindow.pyc
-rw-r--r-- neteler/gis   65575 2013-11-03 01:25 grass-7.0.0RC1/gui/wxpython/nviz/wxnviz.pyc
-rw-r--r-- neteler/gis    1189 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/nviz/main.pyc
-rw-r--r-- neteler/gis    8674 2014-01-13 22:26 grass-7.0.0RC1/gui/wxpython/wxplot/histogram.pyc
-rw-r--r-- neteler/gis    9347 2014-04-19 22:40 grass-7.0.0RC1/gui/wxpython/wxplot/scatter.pyc
-rw-r--r-- neteler/gis   38632 2014-04-19 22:40 grass-7.0.0RC1/gui/wxpython/wxplot/dialogs.pyc
-rw-r--r-- neteler/gis     236 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/wxplot/__init__.pyc
-rw-r--r-- neteler/gis   17797 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/wxplot/base.pyc
-rw-r--r-- neteler/gis   14035 2014-04-19 22:40 grass-7.0.0RC1/gui/wxpython/wxplot/profile.pyc
-rw-r--r-- neteler/gis     253 2013-04-21 23:37 grass-7.0.0RC1/gui/wxpython/lmgr/__init__.pyc
-rw-r--r-- neteler/gis    2345 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/lmgr/menudata.pyc
-rw-r--r-- neteler/gis    3702 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/icons/icon.pyc
-rw-r--r-- neteler/gis     166 2013-09-25 21:03 grass-7.0.0RC1/gui/wxpython/icons/__init__.pyc
-rw-r--r-- neteler/gis     627 2014-05-07 22:47 grass-7.0.0RC1/gui/wxpython/icons/grass_icons.pyc

Attachments (1)

grass-release-remove-pyc.patch (407 bytes) - added by Bas Couwenberg 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Bas Couwenberg

comment:1 Changed 6 years ago by neteler

Keywords: python added; patch removed
Priority: normalblocker

Thanks for reporting this.

The following directories are affected:

make distclean

find . -name '*.pyc' | rev | cut -d'/' -f2- | rev | sort -u
./gui/wxpython/core
./gui/wxpython/gui_core
./gui/wxpython/icons
./gui/wxpython/lmgr
./gui/wxpython/location_wizard
./gui/wxpython/mapdisp
./gui/wxpython/mapwin
./gui/wxpython/modules
./gui/wxpython/nviz
./gui/wxpython/wxplot

IMHO we need to fix "make distclean" here (fixing the release procedure is rather a work around)

comment:2 in reply to:  1 Changed 6 years ago by Bas Couwenberg

Replying to neteler:

IMHO we need to fix "make distclean" here (fixing the release procedure is rather a work around)

How about this:

Index: Makefile
===================================================================
--- Makefile    (revision 64319)
+++ Makefile    (working copy)
@@ -122,6 +122,7 @@
        -rm -f ChangeLog ChangeLog.bak $(ERRORLOG) grass.pc
        -rm -f include/config.h include/version.h
        -rm -f include/Make/Platform.make include/Make/Doxyfile_arch_html include/Make/Doxyfile_arch_latex 2>/dev/null
+       -find . -type f -name "*.pyc" -delete
 
 include $(MODULE_TOPDIR)/include/Make/Install.make
 include $(MODULE_TOPDIR)/include/Make/Docs.make

comment:3 Changed 6 years ago by neteler

I just checked, in theory the *.pyc removal is in the "make clean" target:

http://trac.osgeo.org/grass/browser/grass/trunk/include/Make/Rules.make#L47

I suppose that it does not descend into the subdirs mentioned in #comment:1 which will be an issue in gui/wxpython/Makefile

comment:4 in reply to:  3 Changed 6 years ago by Bas Couwenberg

Replying to neteler:

I suppose that it does not descend into the subdirs mentioned in #comment:1 which will be an issue in gui/wxpython/Makefile

None of the directories containing .pyc files have a Makefile, and those directories are not included in the SUBDIRS list in gui/wxpython/Makefile.

I suppose the fix could be to include a minimal Makefile in those directories that does not nothing except include the clean target for the .pyc removal.

comment:5 Changed 6 years ago by cmbarton

I don't know if this is the cause or not, but these are the modules that always generate errors during compilation on the Mac.

Michaeo

comment:6 Changed 6 years ago by neteler

Resolution: fixed
Status: newclosed

Cleanup of *.pyc added in r64324 (trunk) and r64325 (relbranch70).

It includes, just to be sure, also the suggested cleanup command in the release procedure.

Thanks, closing.

comment:7 Changed 5 years ago by cmbarton

FWIW, I am still getting errors during compilation of 7.0 release branch for the following:

/Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/animation /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/mapswipe /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/gmodeler /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/rlisetup /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/psmap /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/dbmgr /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/vdigit /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/iclass /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/gcp /Users/cmbarton/grass_source/releasebranch_7_0/gui/wxpython/timeline

Michael

comment:8 in reply to:  7 Changed 5 years ago by wenzeslaus

Keywords: pyc added

Replying to cmbarton:

FWIW, I am still getting errors during compilation of 7.0 release branch for the following: ...

I believe you meant to post it to #1819.

Also here are some tips on using Trac Tickets: To insert things verbatim, use {{{ and }}} on separate lines before and after the verbatim text. This is especially advantageous for program outputs where you want to safe newlines and other whitespace. See WikiFormatting linked above the input box for more options. To ensure that it is working as you intended, you can use Preview button at the bottom.

Note: See TracTickets for help on using tickets.