Opened 5 years ago

Closed 5 years ago

#2495 closed defect (invalid)

Java runtime error

Reported by: ragola Owned by: grass-dev@…
Priority: normal Milestone: 6.4.5
Component: Installation Version: unspecified
Keywords: java, runtime, gui startup Cc:
CPU: OSX/Intel Platform: MacOSX

Description

I'm attempting to open the GRASS-7 (3 beta) through Yosemite and the following message appears:

Starting GRASS GIS... No Java runtime present, requesting install. ERROR: Invalid return code from GUI startup script. Please advise GRASS developers of this error. Exiting...

All framework packages were installed prior with no issue and I have reinstalled Java 8. Any assistance is much appreciated.

-Rich G.

Change History (1)

comment:1 Changed 5 years ago by kyngchaos

Resolution: invalid
Status: newclosed

This is not a GRASS bug. This comes from the GDAL framework 1.11.0, where Java 6, not Java 8, is required for the MDB driver. I have removed the MDB driver in GDAL 1.11.1, and will eventually make it an optional GDAL plugin.

Update GDAL.

Note: See TracTickets for help on using tickets.