Opened 5 years ago

Closed 5 years ago

#2405 closed defect (duplicate)

WXGUI-3D view, workspace not saving all the position changes made

Reported by: spareeth Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-releasebranch70
Keywords: wxNVIZ Cc:
CPU: Unspecified Platform: Linux

Description

Hi

I am preparing a 3D workspace to use it as input to the g.gui.animation tool. When I make changes in the map display, the changes are not reflected in the layer manager > 3D view > view tab and in the saved workspace file.

But when I make changes in the layer manager > 3D view > view tab, the workspace is saved appropriately with the changed parameters.

It is much easier to set the 3d map position in map display, so nice to get this issue corrected

Best

Sajid

Attachments (1)

nagshead_gxw.diff (1.8 KB) - added by neteler 5 years ago.
Missing position updates in GXW file (wxNVIZ)

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 years ago by annakrat

I am not sure if I understand correctly the problem. When switching from 2D to 3D, the displayed region is always taken from the current 2D extent. For g.gui.animation, save the workspace when you are in 3D mode. Could you please try to explain it again?

comment:2 Changed 5 years ago by neteler

I checked as well (NagsHead? dataset): The issue happens with the convenient "Rotate 3D Scene" button, any change there is not stored in the workspace file, but it stores the display view values from the standard positioning tool.

For the affected few lines in the workspace file, see attached "nagshead_gxw.diff".

Changed 5 years ago by neteler

Attachment: nagshead_gxw.diff added

Missing position updates in GXW file (wxNVIZ)

comment:3 Changed 5 years ago by annakrat

Resolution: duplicate
Status: newclosed

Closing as duplicate of #1954.

Note: See TracTickets for help on using tickets.