Opened 12 years ago

Closed 12 years ago

#2 closed defect (wontfix)

grass-6.2.3 and flex-2.5.34, missing the description.html

Reported by: stumbles Owned by: neteler
Priority: major Milestone: 6.4.0
Component: Default Version: unspecified
Keywords: Cc: grass-dev@…
CPU: Unspecified Platform: Unspecified

Description (last modified by neteler)

Using gcc-4.2.2, glibc-2.7 and flex-2.5.34. The make goes fine till it gets to generating HTML manual pages and fails with;

Following modules are missing the 'description.html' file in src code:


GRASS GIS compilation log


Started compilation: Thu Dec 27 06:56:30 EST 2007 -- Errors in: /usr/src/grass-6.2.3/lib/db/sqlp /usr/src/grass-6.2.3/db/drivers/dbf /usr/src/grass-6.2.3/db/drivers/postgres /usr/src/grass-6.2.3/db/drivers/ogr -- Finished compilation: Thu Dec 27 06:57:17 EST 2007 (In case of errors please change into the directory with error and run 'make') make: * [default] Error 1

So I cd to /usr/src/grass-6.2.3/lib/db/sqlp and run make which then gives;

root@sidney /usr/src/grass-6.2.3/lib/db/sqlp # make
flex lex.l
lex.l:35: bad character: %
lex.l:35: unknown error processing section 1
lex.l:35: unknown error processing section 1
lex.l:35: bad character: 1
lex.l:35: bad character: 2
lex.l:35: bad character: 0
lex.l:35: bad character: 0
make: *** [lex.yy.c] Error 1

The remaining directories /usr/src/grass-6.2.3/db/drivers/dbf, /usr/src/grass-6.2.3/db/drivers/postgres and /usr/src/grass-6.2.3/db/drivers/ogr fail on the make because it cannot find;

/usr/bin/ld: cannot find -lgrass_sqlp collect2: ld returned 1 exit status make: * usr/src/grass-6.2.3/dist.i686-pc-linux-gnu/driver/db/dbf Error 1

The error shown for /usr/src/grass-6.2.3/lib/db/sqlp looks very similar to a recent problem I had with teTeX and flex-2.5.34. A small snip of that particular error looks like;

 gcc -DHAVE_CONFIG_H  -I. -I. -I../.. -I../.. -I.. -I./..  -O2 -march=athlon64 -pipe  -c y_tab.c -o y_tab.o
    flex -l ./pl.l
    ./pl.l:68: bad character: %
    ./pl.l:68: unknown error processing section 1
    ./pl.l:68: unknown error processing section 1
    ./pl.l:68: bad character: 4
    ./pl.l:68: bad character: 0

Change History (5)

comment:1 Changed 12 years ago by neteler

Cc: grass-dev@… added
Component: Docsdefault
Description: modified (diff)

developers,

is there any known issue with flex-2.5.34?

comment:2 in reply to:  1 Changed 12 years ago by martinl

Replying to neteler:

developers,

is there any known issue with flex-2.5.34?

see e.g.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=464659

flex-2.5.34 produces the same error on my machine (Debian Sid).

comment:3 Changed 12 years ago by hamish

Milestone: 6.3.06.4.0

comment:4 Changed 12 years ago by neteler

Seems to be fixed in flex/2.5.34-2.1

comment:5 Changed 12 years ago by martinl

Resolution: wontfix
Status: newclosed

Confirmed, with flex >= 2.5.34-2.1 problem solved. Closing this tickets. Martin

Note: See TracTickets for help on using tickets.