Opened 7 years ago

Closed 7 years ago

#1896 closed defect (fixed)

d.graph in console tries to add mapset

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: unspecified
Keywords: Cc:
CPU: Unspecified Platform: Unspecified

Description

I just tried to use d.graph to display a legend made with d.thematic.chart.

Here is the command: d.graph input=/Users/cmbarton/chartlegend

Here is the error:

Command 'd.graph input=/Users/cmbarton/chartlegend@spatialtech2012' failed Details: Graph file </Users/cmbarton/chartlegend@spatialtech2012> not found

The console parsing algorithm is trying to add the mapset name to the text file with d.graph commands. This is in 7.0. It may also be a problem in other versions.

Change History (4)

comment:1 Changed 7 years ago by annakrat

Should be fixed (r55180). In grass 6.4, it is possible to display it only as a command layer which works.

Anna

comment:2 Changed 7 years ago by cmbarton

You are right. It works as a command layer in 6.4. The results are really ugly, but that is not a fault of the gui.

Michael

comment:3 Changed 7 years ago by cmbarton

This works now in GRASS 7. Thanks!

Michael

comment:4 Changed 7 years ago by cmbarton

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.