Opened 7 years ago

Closed 3 years ago

#1876 closed defect (worksforme)

pressing "save" on Digitization settings dialog raises error

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.5
Component: wxGUI Version: svn-trunk
Keywords: vdigit Cc:
CPU: Unspecified Platform: MacOSX

Description

Here is the error:

Traceback (most recent call last):
  File "/Applications/GRASS/GRASS-7.0.app/Contents/MacOS/etc
/gui/wxpython/vdigit/preferences.py", line 664, in OnSave

self.UpdateSettings()
  File "/Applications/GRASS/GRASS-7.0.app/Contents/MacOS/etc
/gui/wxpython/vdigit/preferences.py", line 742, in
UpdateSettings

item = tree.FindItemByData('maplayer', mapLayer)
AttributeError
:
'LayerList' object has no attribute 'FindItemByData'

Change History (7)

comment:1 Changed 7 years ago by wenzeslaus

I'm not able to reproduce it. Please, tell me the steps. And for sure, do svn up because there was some changes.

comment:2 Changed 7 years ago by cmbarton

Start digitizing a vector map (in wxPython display). Open preferences dialog. Click "save" instead of apply.

The dialog does not close and the error text appears in the console. I don't know whether or not the preferences are actually changed or not.

Michael

comment:3 Changed 7 years ago by wenzeslaus

I'm not able to reproduce it. Saving is without an error. There can be an error like this but I haven't found anything so far in the source code which can cause it.

comment:4 Changed 7 years ago by martinl

Component: DefaultwxGUI
Keywords: vdigit added

comment:5 Changed 7 years ago by martinl

Platform: UnspecifiedMacOSX

comment:6 Changed 3 years ago by martinl

Milestone: 7.0.07.0.5

comment:7 Changed 3 years ago by martinl

Resolution: worksforme
Status: newclosed

No activity last 4 years, closing, feel free to reopen if needed.

Note: See TracTickets for help on using tickets.