Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1875 closed defect (fixed)

Wrong output of v.overlay.and between lines and polygon in 6.4.3

Reported by: GG1234 Owned by: grass-dev@…
Priority: normal Milestone: 6.4.3
Component: LibVector Version: 6.4.3 RCs
Keywords: Cc:
CPU: x86-64 Platform: MSWindows 7

Description

Hello to all,

First of all thank you all for the great work you are all collectively doing, I'm very often impressed by the power of open GIS.

I have been struggling with a problem on Grass 6.4.3RC1 and 6.4.3RC2 with the v.overlay.and function. I tried to clip a line network on a single polygon, and the output is wrong : some lines are missing, some lines are there that should not be. The problems occur with lines that intersect with the polygon's boundary.

I tried with different sets of data, and with simple features I created for the test in Grass. Same wrong results.

I tried to use the same data with Grass 6.4.2 on my computer and on other computers runnig 6.4.2 and it worked on all PCs.

I tried to upgade one PC in 6.4.2 to 6.4.3 and did the same test : v.overlay.and produced the same erroneous output.

NB : I setup Grass 6.4.3 on my PC through osgeo4w, and 6.4.2 through the windows standalone installer. I also just tried with the 6.4.3.RC2 standalone installer and the output was also wrong.

If it wasn't for my boss, I would switch from Windosw to the Dark Side of the Force...

Can someone else test this function in 6.4.3 ?

Attachments (1)

Sans titre.png (15.1 KB) - added by GG1234 7 years ago.
Avira_Message

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by GG1234

Attachment: Sans titre.png added

Avira_Message

comment:1 Changed 7 years ago by GG1234

I don't know if it is linked but I have the attached message when I setup Grass 6.4.3

comment:2 in reply to:  description ; Changed 7 years ago by mmetz

Replying to GG1234:

I have been struggling with a problem on Grass 6.4.3RC1 and 6.4.3RC2 with the v.overlay.and function. I tried to clip a line network on a single polygon, and the output is wrong : some lines are missing, some lines are there that should not be. The problems occur with lines that intersect with the polygon's boundary.

Please try GRASS 6.4 r54954, it works now for me.

Markus M

comment:3 in reply to:  2 ; Changed 7 years ago by GG1234

Resolution: fixed
Status: newclosed

Great ! It works !

Thank you for the quick help and debug. Since I'm there just a few additional questions :

  • QGS project file periodically and very regularly crashes QGIS, often when upgrading versions on my Windows OSGEO4W setup. About once every three months, per project which is quite a lot. Is it the same on Ubuntu or other Linux distributions ?

When I try repairing these files, it seems to me (but with little investigation) that openlayers plugin seem to be the cause. Am I the only one to suffer from this and if not could it be possible to make Qgis more stable with these files, loading only valid layers and poping the usual warning when necessary ?

  • When multiple Grass are setup with OSGEO4W, how can I know which Grass is used in the Qgis-Grass plugin and could it be possible to switch between Grass versions ? (more a OSGEO4W question) Same question but with a standalone Grass setup ?
  • Out of curiosity, what was the cause of this bug ? Was it a side effect of a code optimisation of the function ?
  • Regarding the Avira message, to your opinion is it an Avira deffect or a Grass deffect ? Am I the only one having this ?

comment:4 in reply to:  3 Changed 7 years ago by GG1234

Regarding the QGS file crash, I believe they systematically crash when openlayers is not setup and an openlayers layer is loaded. Should I file a new bug ?

comment:5 in reply to:  3 ; Changed 7 years ago by mmetz

Replying to GG1234:

Great ! It works !

Thank you for the quick help and debug. Since I'm there just a few additional questions :

  • QGS project file periodically and very regularly crashes QGIS, often when upgrading versions on my Windows OSGEO4W setup. About once every three months, per project which is quite a lot. Is it the same on Ubuntu or other Linux distributions ?

When I try repairing these files, it seems to me (but with little investigation) that openlayers plugin seem to be the cause. Am I the only one to suffer from this and if not could it be possible to make Qgis more stable with these files, loading only valid layers and poping the usual warning when necessary ?

You will most probably get more feedback on the QGIS mailing list about these problems.

  • When multiple Grass are setup with OSGEO4W, how can I know which Grass is used in the Qgis-Grass plugin and could it be possible to switch between Grass versions ? (more a OSGEO4W question) Same question but with a standalone Grass setup ?

For Windows, this is probably hard-coded in QGIS. Better ask on the QGIS mailing list to make sure.

  • Out of curiosity, what was the cause of this bug ? Was it a side effect of a code optimisation of the function ?

Yes, it was a side effect of optimization. v.overlay was until recently terribly slow and had some bugs when overlaying areas areas, I fixed it in trunk but did not backport all fixes.

  • Regarding the Avira message, to your opinion is it an Avira deffect or a Grass deffect ? Am I the only one having this ?

An Avira mystery. I have a Windows machine for testing, also with Avira, and do not get this message.

Markus M

comment:6 in reply to:  5 Changed 7 years ago by GG1234

Ok, thanks again Markus. Done for the Feature #7114 and the Bug #7113

Gen.

Note: See TracTickets for help on using tickets.