Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1831 closed defect (fixed)

wxgui d.vect: layer option should show default applied (1), not -1

Reported by: mlennert Owned by: grass-dev@…
Priority: critical Milestone: 7.0.0
Component: wxGUI Version: svn-trunk
Keywords: d.vect Cc:
CPU: Unspecified Platform: Unspecified

Description

The d.vect gui in the wxgui shows -1 by default for the layer parameter. However, the default in grass6 is 1. This creates confusion for the user. Is there a way to have the layer option in the GUI show the actual default value ?

This might be more generic than the specific case of d.vect and layers. I just happened to notice it here since my students were very confused after using v.net to connect nodes to a network to then not see those nodes, even though the layer option showed -1 in the GUI.

Moritz

Change History (9)

comment:1 Changed 7 years ago by marisn

Could be related to #1749 ?

comment:2 in reply to:  1 ; Changed 7 years ago by mlennert

Replying to marisn:

Could be related to #1749 ?

Possibly, although I cannot reproduce #1749 on either 6.4.2, 64release or trunk. Which version are you using to produce this ?

Moritz

comment:3 in reply to:  2 Changed 7 years ago by marisn

Just tested with a fresh svn up && distclean && make on trunk r54265 and the issue #1749 with GUI/executed command mismatch is still present. I would assume it might have the same root cause as for this issue somewhere in d.vect wxGUI layer switching magic code.

Replying to mlennert:

Replying to marisn:

Could be related to #1749 ?

Possibly, although I cannot reproduce #1749 on either 6.4.2, 64release or trunk. Which version are you using to produce this ?

Moritz

comment:4 Changed 7 years ago by martinl

Milestone: 6.4.37.0.0
Version: 6.4.2svn-trunk

comment:5 Changed 7 years ago by marisn

Milestone: 7.0.06.4.3
Priority: normalblocker
Version: svn-trunk6.4.3 RCs

Just tested on 6.4.3RC2 on Windows. It causes a huge confusion. Sorry, as this is a regression*, it must be fixed before new release.

  • A software regression is a software bug which makes a feature stop functioning as intended after a certain event. In this case - it was working just fine in previous 6.4.x releases and has been introduced by backporting from trunk.

comment:6 Changed 7 years ago by annakrat

Please try r55116.

comment:7 in reply to:  6 Changed 7 years ago by mlennert

Resolution: fixed
Status: newclosed

Replying to annakrat:

Please try r55116.

Yep, this solves the specific issue reported in this bug, so I'll close it.

Thank you !

Moritz

comment:8 Changed 7 years ago by neteler

Milestone: 6.4.37.0.0
Priority: blockercritical
Version: 6.4.3 RCssvn-trunk

I have the same troubles in GRASS 7 - reopen this bug report?

Add new vector -> choose name -> Layer is -1 -> hence no column can be selected for display

comment:9 Changed 7 years ago by annakrat

But in grass7 -1 is default I think. The issue is different - the attrcolumn should be bound to llayer, not to layer option. I think it deserves a new ticket. It is quite difficult to solve this because part of the dependencies between widgets in auto-generated modules is in gui and in parser options and there are many exceptions to handle (like this). Without better parameter description it is hard to solve these issues in gui.

Note: See TracTickets for help on using tickets.