Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1717 closed enhancement (fixed)

layer remove does not work on multiple selections

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 6.4.4
Component: wxGUI Version: svn-releasebranch64
Keywords: layer manager, multiselection Cc:
CPU: Unspecified Platform: Unspecified

Description

You can make multiple selections in the layer manager, but you can't DO anything with multiple selections (like move or remove them). We should either not permit multiple selections (I think it is a flag for the tree control) or fix it so that you can do something with multiple selections.

Change History (12)

comment:1 Changed 7 years ago by martinl

Component: DefaultwxGUI
Keywords: layer manager multiselection added

comment:2 Changed 7 years ago by neteler

Milestone: 6.4.36.4.4
Type: defectenhancement
Version: unspecifiedsvn-releasebranch64

On Sun, Sep 2, 2012 at 10:07 AM, Paulo van Breugel <p.vanbreugel@…> wrote:

Just airing my opinion: it would be really, really, good if the second option would be possible, having the ability to do something (like delete) multiple selection. I would make working with layers that much easier.

I have the same wish. When working with many layers (e.g., after multi-layer import from GeoTIFF), this missing feature arises.

comment:3 Changed 7 years ago by annakrat

Are you sure you can't remove them? It's working for me. There are 3 enabled options - remove, zoom, set region.

I recently fixed layer selection in grass 7 (#1616), seems that nobody tested yet... I'd like to backport it soon.

Anna

comment:4 Changed 7 years ago by cmbarton

I tested this on GRASS 7 compiled yesterday. Removing, moving, and zooming only affects one of the maps selected.

Michael

comment:5 Changed 7 years ago by annakrat

Are we really talking about the same thing? For example when I select 2 layers and choose 'Set computational region from selected maps' this command is executed (copied from command output):

g.region rast=elevation@PERMANENT,aspect@PERMANENT -p

So this is ok. Is it possible that it's not working on Mac? I agree that it is not possible to move them by dragging.

comment:6 Changed 7 years ago by annakrat

Maybe the different behaviour comes from different version of wx. I have quite old 2.8.10.1 which is working ok.

comment:7 Changed 7 years ago by annakrat

Could you try r53064 in grass7?

comment:8 Changed 7 years ago by annakrat

Resolution: fixed
Status: newclosed

Fix confirmed in http://lists.osgeo.org/pipermail/grass-dev/2012-September/059815.html, backported in r53070 and r53071 together with changes related to ticket #1616.

comment:9 Changed 7 years ago by cmbarton

We are talking about the same thing. I put 3 maps in the layer manager, select them all and click 'remove'. One is removed only. Click again and it says that nothing is selected. Select 2 maps covering different geographical areas and 'zoom to map'. It zooms to only one of the maps. Create a group; select 3 maps and drag them to the group. Only one moves to the group.

I am just getting around here in Arizona this morning and have to meet my daughter for breakfast :-) because it is a holiday. I'll test once I get back. Thanks much.

Michael

comment:10 Changed 7 years ago by cmbarton

I can confirm that this DOES work in GRASS 7 now. Thanks much. One caveat, however. If you select a raster and a vector and zoom to map(s), it will only zoom to EITHER the raster OR the vector, not to the combined raster and vector.

Michael

comment:11 Changed 7 years ago by annakrat

It seems to me that the problem is in g.region. What is g.region supposed to do with both parameters rast and vect?

comment:12 Changed 7 years ago by cmbarton

good question. I think g.region used to expand to fit all maps of any types, but I haven't tried it recently by itself recently.

Michael

Note: See TracTickets for help on using tickets.