Opened 7 years ago

Closed 7 years ago

#1706 closed defect (fixed)

wingrass: open attribute table fails

Reported by: hellik Owned by: grass-dev@…
Priority: critical Milestone: 6.4.3
Component: wxGUI Version: svn-releasebranch64
Keywords: wingrass, db Cc:
CPU: x86-64 Platform: MSWindows 7

Description

tested here with

osgeo4w-grass6.4.3svn-r52845 osgeo4w-grass6.5.5svn-r52844 osgeo4w-grass7.0svn-r52843

and the nc-sample dataset:

  • load for example vector firestation to the map display
  • click button to open attribute table or right click open attribute table
  • error messages pops up (screenshot attached)

Attachments (1)

grass_atm_001_23082012_133237.png (12.4 KB) - added by hellik 7 years ago.
error message

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by hellik

error message

comment:1 in reply to:  description Changed 7 years ago by hellik

Replying to hellik:

  • load for example vector firestation to the map display
  • click button to open attribute table or right click open attribute table
  • error messages pops up (screenshot attached)

additional information:

  • error message (translated from german): command "columns" is either false or couldn't be found
  • the attribute table opens, but there is no content in it

comment:2 Changed 7 years ago by neteler

I tried with r52862 G6.4.svn on Linux in English and in German locale, no such problem. However, the 'command "columns"' problem might have to do with a potentially i18N tagging? I cannot trace the message in the .po files, perhaps it comes from Windows itself? Because Google shows quite some hits with

"der Befehl ist entweder falsch geschrieben oder konnte nicht gefunden werden"

comment:3 in reply to:  2 Changed 7 years ago by hellik

Replying to neteler:

However, the 'command "columns"' problem might have to do with a potentially i18N tagging? I cannot trace the message in the .po files, perhaps it comes from Windows itself?

switched in wingrass7 the language (Settings -> Preferences -> Appearance -> Choose language (requires to save and GRASS restart): en), the error remains.

comment:4 Changed 7 years ago by annakrat

This error is caused by changes for #1633 and more information is in the discussion here

comment:5 Changed 7 years ago by annakrat

I disabled the fs option (which was causing the problem) for Windows in r53233. Please test if it is working again.

Anna

comment:6 in reply to:  5 Changed 7 years ago by hellik

Replying to annakrat:

I disabled the fs option (which was causing the problem) for Windows in r53233. Please test if it is working again.

now it works again.

thanks

comment:7 Changed 7 years ago by annakrat

Changed in all branches (r53244, r53245). If you agree we can close this ticket (and the new one #1738).

comment:8 Changed 7 years ago by hellik

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.