Opened 8 years ago

Closed 20 months ago

Last modified 20 months ago

#1697 closed defect (fixed)

zoom out centering problem

Reported by: cmbarton Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: wxGUI Version: svn-releasebranch64
Keywords: zoom Cc:
CPU: All Platform: All

Description

When zooming out, instead of centering the display on the point clicked (as zoom in does), it shifts the center of the display to the point clicked. Same with a box zoom.

Change History (8)

comment:1 Changed 8 years ago by annakrat

Hi,

it should be fixed in r52745 (grass 7). This bug was probably not caused by recent changes in zooming and I didn't realize it because I use almost only mouse wheel for zooming. Zooming out with box seems to be quite ok for me. I'm not sure it works perfectly but the result is what I would expect. The problem is that it's quite difficult to imagine what zooming out with box exactly does.

I'll backport it if you agree.

Anna

comment:2 Changed 8 years ago by cmbarton

Thanks Anna. I'll test it today and let you know. I don't use the wheel zooming because with the Mac trackpad/mouse it is always zooming by mistake.

Michael

comment:3 Changed 8 years ago by cmbarton

Anna,

This fixes the point zoom out.

I'm still not sure what the box zoom out is doing. As you say, it is more difficult to imagine what a box zoom out does. There have been discussions (some heated) in the past about these angels dancing on the head of a pin.

IMHO, the most logical behavior for a zoom-out box is the inverse of a zoom-in box. The zoom in box adjusts the display so that the area defined by the box expands to fill the display window. A large box will do only a little zooming, while a tiny box will do a lot of zooming.

For the inverse, the view should be adjusted so that the area that fills the display window shrinks and moves to fill the box (with the rest of the display adjusting accordingly). A large box will do a little shrinking and a tiny box will do a lot of shrinking. My experience is that while the calculations to do this are not difficult in and of themselves, it is conceptually complicated to imagine and figure out what the calculations are.

This is sort of what is happening now, but a tiny box does not do a lot of shrinking.

Fixing the point zoom-out helps a lot though.

Michael

comment:4 Changed 8 years ago by cmbarton

The zoom out with a single click is working well in GRASS 7. The box zoom out is the same as before. The improvement to zoom out with a mouse click should probably be backported to GRASS 6.x

Michael

comment:5 Changed 8 years ago by annakrat

Keywords: zoom added

Backported in r53057, r53058. The problem with zooming out with box is still there so we keep this ticket open.

comment:6 Changed 4 years ago by neteler

Milestone: 6.4.36.4.6

comment:7 Changed 20 months ago by cmbarton

Resolution: fixed
Status: newclosed

This seems to be fixed in all current versions of GRASS 7. Closing

comment:8 Changed 20 months ago by martinl

Milestone: 6.4.67.0.0
Note: See TracTickets for help on using tickets.