Opened 14 years ago

Last modified 7 years ago

#141 reopened defect

Georectifier throws error if user completes form by typing

Reported by: RRosario Owned by: grass-dev@…
Priority: minor Milestone: 6.4.6
Component: Tcl/Tk Version: 6.3.0 RCs
Keywords: georectify, gis.m Cc:
CPU: Unspecified Platform: Unspecified

Description

In the dialog box that is displayed after Georectify is selected from the File menu, if a user types in the information instead of clicking on the labeled buttons to fill the fields, the following error is displayed:

Error: can't read "output": no such variable

Problem is resolved by using point-and-click to select the necessary group, mapset and map raster.

Change History (8)

comment:1 in reply to:  description Changed 14 years ago by 4everskiff

Replying to RRosario:

In the dialog box that is displayed after Georectify is selected from the File menu, if a user types in the information instead of clicking on the labeled buttons to fill the fields, the following error is displayed:

Error: can't read "output": no such variable

Problem is resolved by using point-and-click to select the necessary group, mapset and map raster.

Could you please check it out with WinGRASS 6.3.0? Thanks

Marco

comment:2 Changed 14 years ago by cmbarton

Since my class is over, I don't have as many ways to test this on Windows. I've tried it on my Mac and typing is no problem. What happens if you press <return> after typing in a field?

Michael

comment:3 Changed 13 years ago by hamish

CPU: Unspecified
Keywords: gis.m added; wingrass windows native output no such variable removed
Platform: Unspecified

Hi,

I can reproduce this in 6.4.0rc4 wingrass + 6.5svn on Linux.

  • File -> Georectify
  • Click in "select mapset" box, type "foo"
  • [tab] to "select group", type "bar"
  • [tab] to "select map", type "baz"
  • click [start georectifying] -> error window.
  • click [ok] GCP table opens as expected

full error message is:

can't read "output": no such variable
can't read "output": no such variable
    while executing
"puts $output "# Ground Control Points File""
    (procedure "GRMap::savegcp" line 17)
    invoked from within
"GRMap::savegcp"
    (procedure "GRMap::gcp_error" line 24)
    invoked from within
"GRMap::gcp_error"
    (procedure "GRMap::gcpwin" line 121)
    invoked from within
"GRMap::gcpwin"
    (procedure "GRMap::refmap" line 33)
    invoked from within
"GRMap::refmap"
    ("uplevel" body line 1)
    invoked from within
"uplevel \#0 $cmd"
    (procedure "Button::_release" line 18)
    invoked from within
"Button::_release .grstart.mf.frame.start.a"
    (command bound to event)

Hamish

comment:4 Changed 13 years ago by hamish

Summary: wingrass native: Georectifier throws error if user completes form by typingGeorectifier throws error if user completes form by typing

comment:5 Changed 8 years ago by wenzeslaus

Resolution: wontfix
Status: newclosed

This is Tcl/Tk? which will be dropped for GRASS 7 and there is GCP Manager in wxGUI (in both GRASS 6.4 and GRASS 7), so closing as wontfix.

comment:6 Changed 8 years ago by hamish

Milestone: 6.4.06.4.5
Resolution: wontfix
Status: closedreopened

bugs are bugs and should be fixed.

regards, Hamish

comment:7 Changed 7 years ago by martinl

Milestone: 6.4.5

Ticket retargeted after milestone closed

comment:8 Changed 7 years ago by martinl

Milestone: 6.4.6
Note: See TracTickets for help on using tickets.