Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#140 closed defect (invalid)

Issues with Windows installer if launched from an XP User Account

Reported by: timmie Owned by: 4everskiff
Priority: major Milestone: 6.3.0
Component: Default Version: 6.3.0
Keywords: windows-native binary Cc: marco.pasetti@…
CPU: Unspecified Platform: Unspecified

Description

I installed GRASS with the native windows installer at http://grass.itc.it/grass63/binary/mswindows/native/

Some issues:

  • Start menu entry hasn't been created
  • not possible to download sample data because computer is behind a corporate firewall/proxy
  • not possible to start the wx GUI although all dependecies are installed

Change History (7)

comment:1 Changed 14 years ago by RRosario

I noticed this same problem on Vista, but not on XP. There appears to be some sort of permissions problem. I suspect this same problem is causing the installer to hang on some systems.

comment:2 Changed 14 years ago by timmie

Sorry, I forgot to add this. I installed on XP as a user that is allowd to install software and is not administrator.

comment:3 Changed 14 years ago by RRosario

Is this issue resolved?

If not, try running the installer as administrator in XP. That resolved the shortcut problem on Vista for me. In any case, this should be fixed.

comment:4 Changed 14 years ago by 4everskiff

Cc: marco.pasetti@… added
Summary: some issues with windows setup/installerIssues with Windows installer if launched from an XP User Account

comment:5 in reply to:  description Changed 14 years ago by 4everskiff

Owner: changed from grass-dev@… to 4everskiff

Replying to timmie:

  • Start menu entry hasn't been created

It should be caused by the account permissions. I need to create a simple user account on my system to check it out.

  • not possible to download sample data because computer is behind a corporate firewall/proxy

This problem cannot be fixed! If a firewall blocks the application to access the internet, the only solution is to tell that firewall to allow the GRASS setup utility to access the internet.

  • not possible to start the wx GUI although all dependecies are installed

Could you provide more detailed information about it? Thanks

More: could you test it also with the new 6.3.0 release? In that case I would change the version from 6.3.0 RCc to 6.3.0 and set the milestone to 6.3.1.

Marco

Marco

comment:6 in reply to:  2 Changed 14 years ago by 4everskiff

Resolution: invalid
Status: newclosed
Version: 6.3.0 RCs6.3.0

Replying to timmie:

Sorry, I forgot to add this. I installed on XP as a user that is allowd to install software and is not administrator.

XP (and maybe also Vista) has only two type fo accounts: Limited and Administrator. The limited accounts are not allowed to install programs, while the administrator are allowed. To check it out I creted a new administrator account on my XP, logged in and installer GRASS: all worked fine.

This said I would close the ticket, since it's not a GRASS installer issue, but a generic Windows issue: if you're not logged as administrator, you cannot install programs on XP (where install means: manage shortcut folders and registry keys, all needed by the GRASS install procedure).

Please, check again the wxPython issue that you reported, and open a new ticket if needed.

Marco

comment:7 Changed 14 years ago by timmie

Hello, installing ad Administrator worked.

Strange because my normal account is allowed to install software...

Regards.

Note: See TracTickets for help on using tickets.