Opened 11 years ago

Closed 11 years ago

#1387 closed defect (fixed)

wingrass65 - wxgui compiling error and not starting

Reported by: hellik Owned by: martinl
Priority: normal Milestone: 6.4.2
Component: wxGUI Version: svn-develbranch6
Keywords: wingrass, wxgui, Cc: grass-dev@…
CPU: x86-32 Platform: MSWindows Vista

Description

self compiled grass65 (Revision: 46657) in the osgeo4w-stack

in the compiling log there is following error regarding the wxgui

/bin/install -c  -m 644 gis_set.py /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gis_set.py
/bin/install -c  -m 644 wxgui.py /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/wxgui.py
/bin/install -c  -m 644 README /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/README
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/compat/__init__.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/compat/subprocess.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/__init__.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/colorrules.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/dbm.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/dbm_base.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/dbm_dialogs.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/debug.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/disp_print.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gcmd.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gcpmanager.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gcpmapdisp.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gdialogs.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/ghelp.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/globalvar.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gmodeler.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/goutput.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gpyshell.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/gselect.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/histogram.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/layertree.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/location_wizard.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/mapdisp.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/mapdisp_command.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/mapdisp_vdigit.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/mapdisp_window.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/mcalc_builder.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/menu.py
  File "c:/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/menu.py", line 52
    self._createMenuItem(menu, *eachItem, menustyle = self.menustyle)
                                                  ^
SyntaxError: invalid syntax
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/menudata.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/menuform.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/nviz.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/nviz_mapdisp.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/nviz_preferences.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/nviz_tools.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/ogc_services.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/preferences.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/profile.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/prompt.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/psmap.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/psmap_dialogs.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/render.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/sqlbuilder.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/toolbars.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/units.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/utils.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/vclean.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/vdigit.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/workspace.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/wxnviz.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/wxvdigit.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gui_modules/wxvdriver.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/icons/__init__.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/icons/grass2_icons.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/icons/grass_icons.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/icons/icon.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/icons/silk_icons.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/gis_set.py
python -m py_compile /c/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/wxgui.py
make[3]: Leaving directory `/c/osgeo4w/usr/src/grass6_devel/gui/wxpython'

trying to start grass65 from the osgeo4w-msys-shell, choosing a location in the wxgui-welcome-gui is possible, but in the next step, the wxgui doesn't start

syringia@NADA /c/osgeo4w/usr/src/grass6_devel/bin.i686-pc-mingw32
$ grass65 -wx
Cleaning up temporary files ...
Starting GRASS ...
WARNUNG: Concurrent mapset locking is not supported on Windows
          __________  ___   __________    _______________
         / ____/ __ \/   | / ___/ ___/   / ____/  _/ ___/
        / / __/ /_/ / /| | \__ \\_  \   / / __ / / \__ \ 
       / /_/ / _, _/ ___ |___/ /__/ /  / /_/ // / ___/ / 
       \____/_/ |_/_/  |_/____/____/   \____/___//____/  

Welcome to GRASS 6.5.svn (2011) 
GRASS homepage:                          http://grass.osgeo.org/
This version running thru:               Bourne Shell (/bin/sh)
Help is available with the command:      g.manual -i
See the licence terms with:              g.version -c
If required, restart the GUI with:       g.gui wxpython
When ready to quit enter:                exit

GRASS 6.5> Traceback (most recent call last):
  File "c:/osgeo4w/usr/src/grass6_devel/dist.i686-pc-mingw32/etc/wxpython/wxgui.py", line 80, in <module>
    from gui_modules import menu
  File "c:\osgeo4w\usr\src\grass6_devel\dist.i686-pc-mingw32\etc\wxpython\gui_modules\menu.py", line 52
    self._createMenuItem(menu, *eachItem, menustyle = self.menustyle)
                                                  ^
SyntaxError: invalid syntax

best regards Helmut

Attachments (1)

menu.diff (1.0 KB ) - added by wenzeslaus 11 years ago.
patch

Download all attachments as: .zip

Change History (6)

in reply to:  description ; comment:1 by hellik, 11 years ago

Replying to hellik:

self compiled grass65 (Revision: 46657) in the osgeo4w-stack

tested also with nightly build WinGRASS-6.5.SVN-r46657-1-Setup.exe

the same error also there

Helmut

in reply to:  1 comment:2 by hellik, 11 years ago

Replying to hellik:

Replying to hellik:

self compiled grass65 (Revision: 46657) in the osgeo4w-stack

tested also with nightly build WinGRASS-6.5.SVN-r46657-1-Setup.exe

and also in the nightly build WinGRASS-6.4.SVN-r46660-1-Setup.exe

Helmut

by wenzeslaus, 11 years ago

Attachment: menu.diff added

patch

comment:3 by wenzeslaus, 11 years ago

It is caused by version of Python <2.6. Problem is in changeset r46397 written by me. I attached the patch. I hope martinl will commit it (I don't have write access).

in reply to:  3 ; comment:4 by martinl, 11 years ago

Cc: grass-dev@… added
Milestone: 6.4.2
Owner: changed from grass-dev@… to martinl
Status: newassigned

Replying to wenzeslaus:

It is caused by version of Python <2.6. Problem is in changeset r46397 written by me. I attached the patch. I hope martinl will commit it (I don't have write access).

right, patch applied in r46662 and backported to devbr6 and relbr64.

in reply to:  4 comment:5 by hellik, 11 years ago

Resolution: fixed
Status: assignedclosed

Replying to martinl:

Replying to wenzeslaus:

It is caused by version of Python <2.6. Problem is in changeset r46397 written by me. I attached the patch. I hope martinl will commit it (I don't have write access).

right, patch applied in r46662 and backported to devbr6 and relbr64.

thanks for the patch, now it's starting again.

Helmut

Note: See TracTickets for help on using tickets.