Opened 11 years ago

Closed 11 years ago

#1380 closed defect (fixed)

WxGUI, menu does not work at all (languages using double-byte characters)

Reported by: naokiueda Owned by: martinl
Priority: blocker Milestone: 6.4.2
Component: wxGUI Version: 6.4.1 RCs
Keywords: encoding, wingrass, cp932 Cc: grass-dev@…
CPU: Unspecified Platform: MSWindows 7

Description

I downloaded latest GRASS6.4.1 and tested.

I tested WX-Python GUI. Windows7, Japanese environment.

Most Menu and commands does not work at all. TckTk GUI forks fine, though. There are error messages shown in command console.

Unless this is solved, WX-Python GUI is useless.

Note that, this may be same problem as OSGEO4W Track ticket#228 by Mr.Hayashi.

Regards, Nao


Error when I put [Add Raster Map] button.


Traceback (most recent call last):

File "C:/Program Files/GRASS 6.4.1/etc/wxpython/wxgui.py",

line 1180, in OnAddRaster

self.curr_page.maptree.AddLayer('raster')

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/layertree.py", line 821, in AddLayer

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/layertree.py", line 882, in PropertiesDialog

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/menuform.py", line 2049, in ParseCommand

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/menuform.py", line 2020, in ParseInterface

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 963, in XML

parser.feed(text)

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 1245, in feed

self._parser.Parse(data, 0) xml.parsers.expat . ExpatError : unknown encoding: line 1, column 30

Error when I put [Add 3D vector Map] button


Traceback (most recent call last):

File "C:/Program Files/GRASS 6.4.1/etc/wxpython/wxgui.py",

line 1307, in OnAddRaster3D

self.curr_page.maptree.AddLayer('3d-raster')

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/layertree.py", line 821, in AddLayer

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/layertree.py", line 886, in PropertiesDialog

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/menuform.py", line 2049, in ParseCommand

File "c:/osgeo4w/usr/src/grass641_release/dist.i686-pc-

mingw32/etc/wxpython/gui_modules/menuform.py", line 2020, in ParseInterface

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 964, in XML

return parser.close()

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 1254, in close

self._parser.Parse("", 1) # end of data xml.parsers.expat . ExpatError : no element found: line 1, column 0

Error when I enter "g.version" in command console


parser.feed(text)

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 1245, in feed

self._parser.Parse(data, 0) xml.parsers.expat . ExpatError : unknown encoding: line 1, column 30

Change History (19)

comment:1 by martinl, 11 years ago

Keywords: encoding wingrass added; WX Python Menu removed

comment:2 by martinl, 11 years ago

Can you try more recent version from http://wingrass.fsv.cvut.cz/grass64/ ?

comment:3 by martinl, 11 years ago

Priority: blockercritical

No answer, downgrading priority...

comment:4 by venkat, 11 years ago

Priority: criticalblocker

The problem still persists in GRASS-6.4.2-SVN, GRASS-6.4.2-RC1, and GRASS-6.4.1. Tried with winGRASS on Windows-7 English and also Japanese version

Can't continue with further tests if d.rast does not start.

in reply to:  4 ; comment:5 by venkat, 11 years ago

Replying to venkat:

The problem still persists in GRASS-6.4.2-SVN, GRASS-6.4.2-RC1, and GRASS-6.4.1. Tried with winGRASS on Windows-7 English and also Japanese version

Can't continue with further tests if d.rast does not start.

The error message when I use the "Add raster Map layer" in the WxGUI

Traceback (most recent call last):

File "C:/Program Files (x86)/GRASS

6.4.SVN/etc/wxpython/wxgui.py", line 1309, in OnAddRaster

self.curr_page.maptree.AddLayer('raster')

File "C:\Program Files (x86)\GRASS

6.4.SVN\etc\wxpython\gui_modules\layertree.py", line 855, in AddLayer

self.PropertiesDialog(layer, show = True)

File "C:\Program Files (x86)\GRASS

6.4.SVN\etc\wxpython\gui_modules\layertree.py", line 920, in PropertiesDialog

completed = (self.GetOptData,layer,params))

File "C:\Program Files (x86)\GRASS

6.4.SVN\etc\wxpython\gui_modules\menuform.py", line 1732, in ParseCommand

blackList = _blackList)

File "c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-

mingw32/etc/python/grass/script/task.py", line 451, in parse_interface

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 963, in XML

parser.feed(text)

File

"c:\OSGeo4W\apps\Python25\lib\xml\etree\ElementTree.py", line 1245, in feed

self._parser.Parse(data, 0) xml.parsers.expat . ExpatError : unknown encoding: line 1, column 30

comment:6 by martinl, 11 years ago

Summary: GRASS6.4.1 WX-Python GUI, menu does not work at allWX-Python GUI, menu does not work at all

in reply to:  5 ; comment:7 by martinl, 11 years ago

Replying to venkat:

probably unrelated

> completed = (self.GetOptData,layer,params))
>   File "C:\Program Files (x86)\GRASS
> 6.4.SVN\etc\wxpython\gui_modules\menuform.py", line 1732, in
> ParseCommand
> 
> blackList = _blackList)

path OK (C:\Program Files (x86)\GRASS 6.4.SVN)

File "c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-

mingw32/etc/python/grass/script/task.py", line 451, in parse_interface

huh (c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-mingw32)

Did you compiled GRASS on your own?

in reply to:  4 ; comment:8 by martinl, 11 years ago

Replying to venkat:

Tried with winGRASS on Windows-7 English and also Japanese version

Do you problem also in English environment?

in reply to:  7 ; comment:9 by venkat, 11 years ago

Replying to martinl:

Replying to venkat:

probably unrelated

> completed = (self.GetOptData,layer,params))
>   File "C:\Program Files (x86)\GRASS
> 6.4.SVN\etc\wxpython\gui_modules\menuform.py", line 1732, in
> ParseCommand
> 
> blackList = _blackList)

path OK (C:\Program Files (x86)\GRASS 6.4.SVN)

File "c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-

mingw32/etc/python/grass/script/task.py", line 451, in parse_interface

huh (c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-mingw32)

Not sure why winGRASS standalone is looking up the osgeo4W directory.

Did you compiled GRASS on your own?

No. I use 6.4.SVN from 6.4.svn:

Have winGRASS and OSGeo4W installed on my machine

in reply to:  8 ; comment:10 by venkat, 11 years ago

Replying to martinl:

Replying to venkat:

Tried with winGRASS on Windows-7 English and also Japanese version

Do you problem also in English environment?

Yes, the problem is also on Windows-7 English environment?

in reply to:  10 comment:11 by venkat, 11 years ago

Replying to venkat:

Replying to martinl:

Replying to venkat:

Tried with winGRASS on Windows-7 English and also Japanese version

Do you problem also in English environment?

Yes, the problem is also on Windows-7 English environment.

The problem also on Windows-7 English environment.

in reply to:  9 comment:12 by martinl, 11 years ago

Replying to venkat:

Not sure why winGRASS standalone is looking up the osgeo4W directory.

moreover, it's looking up the *source code* directory, which is very very strange. Does c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-mingw32 exist on your computer? I presume that yes, and I wonder why. Haven't you compiled GRASS on your Windows machine in the past?

Did you compiled GRASS on your own?

No. I use 6.4.SVN from 6.4.svn:

Are you sure? I wonder how could

c:/osgeo4w/usr/src/grass64_release/dist.i686-pc-mingw32

be created without compiling winGRASS. OSGeo4W GRASS package is installed to

c:\osgeo4w\apps\grass\grass-<version>

in reply to:  10 ; comment:13 by martinl, 11 years ago

Replying to venkat:

Replying to martinl:

Replying to venkat:

Tried with winGRASS on Windows-7 English and also Japanese version

Do you problem also in English environment?

Yes, the problem is also on Windows-7 English environment?

Anyone else with this problem? I wonder that something is bad with your installation, see my previous notes.

in reply to:  13 ; comment:14 by hellik, 11 years ago

Replying to martinl:

Replying to venkat:

Replying to martinl:

Replying to venkat:

Tried with winGRASS on Windows-7 English and also Japanese version

Do you problem also in English environment?

Yes, the problem is also on Windows-7 English environment?

Anyone else with this problem? I wonder that something is bad with your installation, see my previous notes.

tested here http://grass.osgeo.org/grass64/binary/mswindows/native/WinGRASS-6.4.2RC1-1-Setup.exe on a fresh german 64bit-win7-box and on german 32bit-winvista-box, I can't reproduce these errors.

Helmut

in reply to:  14 ; comment:15 by Venkat, 11 years ago

Replying to hellik:

Replying to martinl:

Replying to venkat:

Replying to martinl:

Replying to venkat:

Tried with winGRASS on Windows-7 English and also Japanese version

Do you problem also in English environment?

Yes, the problem is also on Windows-7 English environment?

Anyone else with this problem? I wonder that something is bad with your installation, see my previous notes.

tested here http://grass.osgeo.org/grass64/binary/mswindows/native/WinGRASS-6.4.2RC1-1-Setup.exe on a fresh german 64bit-win7-box and on german 32bit-winvista-box, I can't reproduce these errors.

Thanks for testing. The error cannot be reproduced on your computer because "system locale" is perhaps set to german. System local can be changed from Contro Panel --> Region and Language --> Change system locale. On Japanese Windows-7 the system locale is set to "Japanese". (Japanese/Chinese/Korean are use double byte encoding, unlike English, German etc.). d.rast wxGUI works if I set the "system locale" to English or German (I tried with German too).

The problem that I am reporting is peculiar to languages using double-byte characters (Chinese, Japanese, Korean). You should be able to reproduce the error by setting the Change system locale to Japanese,

Venka

in reply to:  15 comment:16 by hellik, 11 years ago

Replying to Venkat:

Thanks for testing. The error cannot be reproduced on your computer because "system locale" is perhaps set to german. System local can be changed from Contro Panel --> Region and Language --> Change system locale. On Japanese Windows-7 the system locale is set to "Japanese". (Japanese/Chinese/Korean are use double byte encoding, unlike English, German etc.). d.rast wxGUI works if I set the "system locale" to English or German (I tried with German too).

The problem that I am reporting is peculiar to languages using double-byte characters (Chinese, Japanese, Korean). You should be able to reproduce the error by setting the Change system locale to Japanese,

maybe change the title that an encoding issue is here the problem?

Helmut

comment:17 by martinl, 11 years ago

Summary: WX-Python GUI, menu does not work at allWxGUI, menu does not work at all (languages using double-byte characters)

comment:18 by martinl, 11 years ago

Cc: grass-dev@… added
Keywords: cp932 added
Owner: changed from grass-dev@… to martinl
Status: newassigned

See also #1485

comment:19 by martinl, 11 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.