Opened 15 years ago

Closed 14 years ago

#13 closed defect (worksforme)

GRASS OGR Module failing

Reported by: jrobins Owned by: grass-dev@…
Priority: major Milestone: 6.3.0
Component: Default Version: svn-trunk
Keywords: OGR, Cygwin, winGRASS, Tcl/Tk Cc:
CPU: Unspecified Platform: Unspecified

Description (last modified by neteler)

The GDAL/OGR module fails when I try to export ESRI shapefiles from GRASS vectors.

Cygwin/X Output on startup:

Welcome to the XWin X Server Vendor: The Cygwin/X Project Release: 6.8.99.901-4

Contact: cygwin-xfree@…

XWin was started with the following command line:

X :0 -multiwindow -clipboard

_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
winValidateArgs - g_iNumScreens: 1 iMaxConsecutiveScreen: 1
(II) XF86Config is not supported
(II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more information
winDetectSupportedEngines - Windows NT/2000/XP
winDetectSupportedEngines - DirectDraw installed
winDetectSupportedEngines - DirectDraw4 installed
winDetectSupportedEngines - Returning, supported engines 00000007
winSetEngine - Multi Window or Rootless => ShadowGDI
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 1280 height: 800 depth: 32
winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Hello
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
MIT-SHM extension disabled due to lack of kernel support
XFree86-Bigfont extension local-client optimization disabled due to lack of shar
ed memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(--) Using preset keyboard for "English (USA)" (409), type "4"
Rules = "xorg" Model = "pc105" Layout = "us" Variant = "(null)" Options = "(null
)"
(--) 5 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from li
st!
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from
 list!
winPointerWarpCursor - Discarding first warp: 640 400
winInitMultiWindowWM - pthread_mutex_lock () returned.
winProcEstablishConnection - Hello
winMultiWindowXMsgProc - pthread_mutex_lock () returned.
winInitMultiWindowWM - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
cat: /home/John/.Xauthority: No such file or directory
winInitClipboard ()
winProcEstablishConnection - winInitClipboard returned.
winClipboardProc - Hello
DetectUnicodeSupport - Windows NT/2000/XP
winClipboardProc - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the di
splay.
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the disp
lay.
winClipboardProc - XOpenDisplay () returned and successfully opened the display.

winProcSetSelectionOwner - Clipboard not yet started, aborting.
winProcSetSelectionOwner - Clipboard not yet started, aborting.

--Execute 'grass62' at xWin prompt--

Cygwin/X output in Cygwin shell:

winMultiWindowXMsgProcErrorHandler - ERROR: BadWindow (invalid Window parameter)

winMultiWindowXMsgProcErrorHandler - ERROR: BadWindow (invalid Window parameter)

--select spearfish60 location; PERMANENT mapset--

Grass output in xWin shell:

Cleaning up temporary files.....
Starting GRASS ...
/usr/local/grass-6.2.3/etc/Init.sh: line 635: tput: command not found
Welcome to GRASS 6.2.3 (2007) 
GRASS homepage:                          http://grass.itc.it/
This version running thru:               GNU Bash (Cygwin) (/usr/bin/bash.exe)
Help is available with the command:      g.manual -i
See the licence terms with:              g.version -c
If required, restart the graphical user interface with: gis.m &
When ready to quit enter:                exit
GRASS 6.2.3 (spearfish60):~ > 

--error is generated here--
GRASS 6.2.3 (spearfish60):~ > v.out.ogr input=roads type=line dsn=/shapefiles olayer=Road    
Segmentation fault (core dumped)
GRASS 6.2.3 (spearfish60):~ > 

Output in Cygwin shell:

     24 [main] v.out.ogr 2480 _cygtls::handle_exceptions: Error while dumping st
ate (probably corrupted stack)

--data dumped to v.out.ogr.stackdump in my home directory (c:\cygwin\home\John\)--

Is this an OGR problem, or is this a GRASS issue? It started happening recently, but I can now reproduce it reliably. I am running GRASS 6.2.3 on Windows Vista using all the latest updates from Cygwin (v. 1.5.25-7), from the Cygwin/X Project (v. 6.8.99.901-4), and from GDAL (v. 1.3.1-1).

Thanks, John R.

Attachments (1)

v.out.ogr.stackdump (1.1 KB ) - added by jrobins 15 years ago.
Stack dump caused by the error

Download all attachments as: .zip

Change History (4)

by jrobins, 15 years ago

Attachment: v.out.ogr.stackdump added

Stack dump caused by the error

comment:1 by jrobins, 14 years ago

Keywords: winGRASS Tcl/Tk added
Milestone: 6.3.0
Version: unspecifiedsvn-trunk

I also get a similar error in the latest 6.3.svn release (built December 14) from the winGRASS project. After opening the PERMANENT mapset of the spearfish60 data, I ran "v.out.ogr input=roads type=line dsn=/shapefiles olayer=Roads". This generates the following error messages:

Invalid argument: can't _spawnl ERROR: Unable to start driver <dbf>

The module then exits. I ran this from both the text version and Tcl/Tk gui with the same result. My current Tcl version is 8.4.16.0.282109.

comment:2 by neteler, 14 years ago

Description: modified (diff)

in reply to:  description comment:3 by jrobins, 14 years ago

Resolution: worksforme
Status: newclosed

This issue seems to have been resolved in the winGRASS release of GRASS 6.3RC5. The dbf driver now works correctly.

Note: See TracTickets for help on using tickets.