Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5674 closed defect (fixed)

Driver conflicts FileGDB vs OpenFileGDB

Reported by: pelord Owned by: warmerdam
Priority: normal Milestone: 1.11.2
Component: OGR_SF Version: unspecified
Severity: normal Keywords: GDB
Cc:

Description

WHI

When the two driver (FileGDB from ESRI and OpenFileGDB) installed on the same machine, the FileGDB (Esri) is used primarily and the OpenFileGDB is not used.

This may cause script fail due to the version of the GDB.

This line fail with a GDB 9.3 and is susccessful with a 10.x GDB

ogr2ogr -f "GML" test.gml ESSENCE_NAIPF_ORI_PROV.gdb DDE_ ESSEN_NAIPF_ORI_VUE

Same thing for ogrinfo.

Attachments (1)

gdb93_dist.gdb.zip (130.2 KB) - added by pelord 7 years ago.
GDB 9.3 with a geometric layer

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by Even Rouault

Milestone: 1.11.1
Resolution: duplicate
Status: newclosed

I don't think that's true. The order is actually OpenFileGDB and the FileGDB. But as that the OpenFileGDB driver doens't see the DDE_ESSEN_NAIPF_ORI_VUE layer (#5673), there's no chance that the conversion can work.

So closing as a duplicate of #5673.

comment:2 Changed 7 years ago by pelord

Resolution: duplicate
Status: closedreopened

I would lite reactivating the issue.

I use OSGEO4W online installer to manage my GDAL/OGR installation. I use a GDB 9.3 to test this issue, with a geometric layer.

When the ESRI FileGDB driver is not installed, the OpenFileGDB driver open correctly the GDB.

When I install ESRI FileGDB driver, this message is shown:

ogrinfo gdb93.gdb ERROR 1: Error: Failed to open Geodatabase (This release of the GeoDatabase? is e ither invalid or out of date.) ERROR 1: Error: Failed to open Geodatabase (This release of the GeoDatabase? is e ither invalid or out of date.) FAILURE: Unable to open datasource `gdb93.gdb' with the following drivers.

-> FileGDB -> ESRI Shapefile -> MapInfo? File

...

comment:3 Changed 7 years ago by Even Rouault

Hum, this must be true if the FileGDB driver is installed as a plugin, which must be the case in OSGeo4W, in which case it is registered before other drivers. Similar to a recent issue with KEA/HDF5

Changed 7 years ago by pelord

Attachment: gdb93_dist.gdb.zip added

GDB 9.3 with a geometric layer

comment:4 Changed 7 years ago by pelord

I will submit an issue to OSGEO4W instead.

http://trac.osgeo.org/osgeo4w/ticket/455

comment:5 Changed 7 years ago by Even Rouault

OSGeo4W itself is just the packaging. If something must be corrected, it's within the FileGDB driver

comment:6 Changed 7 years ago by Even Rouault

Component: defaultOGR_SF
Milestone: 1.11.2
Resolution: fixed
Status: reopenedclosed

trunk r28411, branches/1.11 r28412 "FileGDB: avoid emitting error when opening a FileGDB v9, so that OpenFileGDB can be tried to open it, in the case FileGDB is a plugin (#5674)"

comment:7 Changed 7 years ago by Even Rouault

trunk r28413 "FileGDB: test fix for #5674"

Note: See TracTickets for help on using tickets.