Opened 7 years ago

Closed 3 years ago

#5624 closed enhancement (wontfix)

gdal2tiles: assess and merge features from maptiler version.

Reported by: hamish Owned by: warmerdam
Priority: normal Milestone: closed_because_of_github_migration
Component: Utilities Version: svn-trunk
Severity: normal Keywords: gdal2tiles
Cc:

Description

Hi,

the maptiler 1.0.beta2 .deb release has a slightly newer version of gdal2tiles.py than either the maptiler svn (on googlecode) or in the gdal/swig/python/scripts/ of that time.

Attached is a diff between r15748 of gdal's copy of the script and the version which shipped with maptiler.

One of the newer features (--srsnodata) was later merged in r16719, perhaps that later commit included a number of other parts of this patch as well? here's the diff between those two revisions:

https://trac.osgeo.org/gdal/changeset?new=16719%40trunk%2Fgdal%2Fswig%2Fpython%2Fscripts%2Fgdal2tiles.py&old=15748%40trunk%2Fgdal%2Fswig%2Fpython%2Fscripts%2Fgdal2tiles.py

New stuff the attached patch:

new profiles: 'gearth' and 'garmin'

new options:

  • --tile-format: Image format of generated tiles - default 'png'
  • --init-dest: Colour used to initialize output, only for 'jpeg' tile format
  • --tilesize: Size of the tiles - default 256
  • -d, --kml-depth: How many levels to store before linking, default 1
  • --kmz: Compress KML files into KMZ format, default for 'gearth' profile
  • --no-kmz: Do not compress KML files into KMZ format, default for 'mercator', 'geodetic' and 'raster' profiles

IMO --tile-format seems to be the most important of these. (see also #2052)

Hamish

Attachments (1)

maptiler_gdal2tiles.patch (72.8 KB) - added by hamish 7 years ago.
diff between gdal2tiles r15748 and maptiler_1.0.beta2_all.deb's version

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by hamish

Attachment: maptiler_gdal2tiles.patch added

diff between gdal2tiles r15748 and maptiler_1.0.beta2_all.deb's version

comment:1 Changed 7 years ago by Even Rouault

Hamish,

As you seem to have interest for gdal2tiles, would you be interested in taking 'ownership' on gdal2tiles as we currently lack a maintener for it ? A much needed feature would be adding a few regression tests for gdal2tiles that we currently lack. Would you be willing to do so ? Such tests could be added in http://trac.osgeo.org/gdal/browser/trunk/autotest/pyscripts

comment:2 Changed 3 years ago by Even Rouault

Milestone: closed_because_of_github_migration
Resolution: wontfix
Status: newclosed

This ticket has been automatically closed because Trac is no longer used for GDAL bug tracking, since the project has migrated to GitHub?. If you believe this ticket is still valid, you may file it to https://github.com/OSGeo/gdal/issues if it is not already reported there.

Note: See TracTickets for help on using tickets.