Opened 11 years ago

Closed 11 years ago

#4238 closed defect (duplicate)

There has some errors in the function of CreateLayer in ogrsdedatasource.cpp

Reported by: phooncloudy Owned by: warmerdam
Priority: highest Milestone:
Component: OGR_SF Version: 1.8.1
Severity: critical Keywords: OGR SDE
Cc:

Description

The error is in the function of CreateLayer in ogrsdedatasource.cpp.

When the parameter of eType is wkbMultiPolygon, the SDE shape type is

SE_AREA_TYPE_MASK.

in SE_AREA_TYPE_MASK condition, the OGRMultiPolygon is not supported.

you must add another flag of SE_MULTIPART_TYPE_MASK;

The code can be modified like this,

else if( wkbFlatten(eType) == wkbPolygon

wkbFlatten(eType) == wkbMultiPolygon )

{

nLayerShapeTypes |= SE_AREA_TYPE_MASK; nLayerShapeTypes |= SE_MULTIPART_TYPE_MASK;

}

the version of SDE c api is : 10

Change History (1)

comment:1 by warmerdam, 11 years ago

Milestone: 1.8.2
Resolution: duplicate
Status: newclosed

This is a duplicate of #4061 already corrected in trunk. If you could confirm the form of the fix in trunk I will backport the change to the 1.8 branch (r22295).

I will note there have been several other improvements to the SDE driver in trunk.

Please make notes on validation of r22295 in #4061.

Note: See TracTickets for help on using tickets.