Opened 11 years ago

Closed 11 years ago

#2711 closed defect (duplicate)

Ili compile fails with Xerces 3.0

Reported by: kyngchaos Owned by: warmerdam
Priority: high Milestone: 1.6.0
Component: OGR_SF Version: 1.6.0
Severity: normal Keywords:
Cc:

Description

Ili driver fails to compile with Xerces 3.0, though GML is OK.

g++ -Os -Wall -DOGR_ENABLED

...

-o ../../o/.libs/iom_utilities.o iom_utilities.cpp: In function 'char* iom_toUTF8(const XMLCh*)': iom_utilities.cpp:178: error: no matching function for call to 'xercesc_3_0::XMLTranscoder::transcodeTo(const XMLCh*&, unsigned int&, unsigned char*, int&, unsigned int&, xercesc_3_0::XMLTranscoder::UnRepOpts?)' /Users/Shared?/unix/xercesc-leo/include/xercesc/util/TransService.hpp:297: note: candidates are: virtual XMLSize_t xercesc_3_0::XMLTranscoder::transcodeTo(const XMLCh*, XMLSize_t, XMLByte*, XMLSize_t, XMLSize_t&, xercesc_3_0::XMLTranscoder::UnRepOpts?) iom_utilities.cpp:183: error: no matching function for call to 'xercesc_3_0::XMLTranscoder::transcodeTo(const XMLCh*&, unsigned int&, unsigned char*, int&, unsigned int&, xercesc_3_0::XMLTranscoder::UnRepOpts?)' /Users/Shared?/unix/xercesc-leo/include/xercesc/util/TransService.hpp:297: note: candidates are: virtual XMLSize_t xercesc_3_0::XMLTranscoder::transcodeTo(const XMLCh*, XMLSize_t, XMLByte*, XMLSize_t, XMLSize_t&, xercesc_3_0::XMLTranscoder::UnRepOpts?) iom_utilities.cpp: In function 'XMLCh* iom_fromUTF8(const char*)': iom_utilities.cpp:198: error: no matching function for call to 'xercesc_3_0::XMLTranscoder::transcodeFrom(unsigned char*, int&, XMLCh*&, int&, unsigned int&, unsigned char*&)' /Users/Shared?/unix/xercesc-leo/include/xercesc/util/TransService.hpp:274: note: candidates are: virtual XMLSize_t xercesc_3_0::XMLTranscoder::transcodeFrom(const XMLByte*, XMLSize_t, XMLCh*, XMLSize_t, XMLSize_t&, unsigned char*) iom_utilities.cpp: In function 'char* iom_toUTF8(const XMLCh*)':

Change History (1)

comment:1 Changed 11 years ago by Even Rouault

Resolution: duplicate
Status: newclosed

Duplicate of #2616

Note: See TracTickets for help on using tickets.