Opened 13 years ago

Closed 11 years ago

#1681 closed defect (fixed)

Add cast to (unsigned char) in all isspace() calls

Reported by: Daniel Morissette Owned by: chaitanya
Priority: normal Milestone: 1.6.1
Component: default Version: unspecified
Severity: normal Keywords:
Cc: Mateusz Łoskot, warmerdam

Description

Ticket #1678 pointed an issue with isspace() that requires casting of the char passed as argument to (unsigned char). The original issue has been fixed in the MITAB driver in ticket 1678, but there are 28 other places using isspace() in the current trunk version of GDAL that may need to be fixed as well (see attached list).

The issue is explained here: http://www.greenend.org.uk/rjk/2001/02/cfu.html#ctypechar

This ticket is to track this.

Attachments (1)

isspace.txt (2.0 KB) - added by Daniel Morissette 13 years ago.
List of calls to isspace() in GDAL trunk

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by Daniel Morissette

Attachment: isspace.txt added

List of calls to isspace() in GDAL trunk

comment:1 Changed 13 years ago by Mateusz Łoskot

Here is longer discussion about this issue:

Assertion in .tab driver

comment:2 Changed 12 years ago by warmerdam

Milestone: 1.5.01.6.0

comment:3 Changed 12 years ago by Mateusz Łoskot

Cc: Mateusz Łoskot added

comment:4 Changed 11 years ago by hobu

This seems like a low intensity and low risk fix for 1.6.1 that just wasn't gotten to. If it can't be done for the 1.6.1 release, please kick it forward to 1.7 or future.

comment:5 Changed 11 years ago by warmerdam

Cc: warmerdam added
Owner: changed from warmerdam to chaitanya

Chaitanya,

Please take care of this in 1.6 branch and trunk.

comment:6 Changed 11 years ago by chaitanya

Resolution: fixed
Status: newclosed

Modified trunk (r16865) and 1.6 (r16866).

Note: See TracTickets for help on using tickets.