Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#94 closed defect (fixed)

multi-layer query broken when one of the layer defines a feature filter

Reported by: tomfukushima Owned by: madair
Priority: P2 Milestone: 1.1
Component: MapGuide Version: 1.0.6
Severity: Major Keywords:
Cc: Browser: All
External ID: Operating System: All
state: Pending Approval

Description

See the MapGuide trac ticket for more details: http://trac.osgeo.org/mapguide/ticket/651. A patch is attached for your review. In case the patch doesn't work (because I hand edited the paths) the corresponding MG change is http://trac.osgeo.org/mapguide/changeset/3260.

Attachments (2)

ticket651.patch (1.2 KB ) - added by tomfukushima 14 years ago.
Defects-1058939.mgp (213.8 KB ) - added by edzimmerman 14 years ago.

Download all attachments as: .zip

Change History (7)

by tomfukushima, 14 years ago

Attachment: ticket651.patch added

by edzimmerman, 14 years ago

Attachment: Defects-1058939.mgp added

comment:1 by edzimmerman, 14 years ago

I attached a package containing an example map. To reproduce the defect 1) Apply the attached package. 2) In MapGuide Studio, create a fusion web layout referencnig the sample map contained in the package. 3) Launch the web browser on fusion web layout url. 4) Set layer visibility as follows: airprt020 (OFF); airprt020 filtered (ON); Sample_World_Countries (ON). 5) Do a window select around some points.

Before the fix, the selection will fail. After the fix, it will succeed. The problem was that use of the $filter variable in Query.php was being overloaded to both store the possible incoming sql filter and to store the possible combined filter of the sql filter and the layer's feature filter. I fixed this be adding a new $combinedFilter variable to eliminate the overloaded use of $filter.

comment:2 by pagameba, 14 years ago

state: NewPending Approval

comment:3 by madair, 14 years ago

(In [1615]) re #94: patch applied

comment:4 by madair, 14 years ago

Resolution: fixed
Status: newclosed

(In [1616]) closes #94: patch applied to trunk

comment:5 by tomfukushima, 14 years ago

Thanks Mike

Note: See TracTickets for help on using tickets.