PostGIS Install Guide

The following is a guideline to install PostGIS onto various operating systems from either prebuilt packages (where maintained) or source.

See the PostGIS/PostgreSQL and other dependency matrix that defines recommended versions of core dependencies for each version of PostGIS.

PostGIS 2.1

  • Ubuntu 12.04 (precise) - uses PostgreSQL 9.1
  • Ubuntu 13.04 (raring) - uses PostgreSQL 9.1
  • Ubuntu 13.10 (saucy) - uses PostgreSQL 9.1

For other systems, just follow the 2.0 guides (from source versions). Keep in mind a few dependencies for PostGIS 2.1:

  • PostgreSQL 9.0, but 9.1 or later recommended
  • GEOS 3.3, but 3.4.0 or later recommended
  • GDAL 1.8, but 1.9 or later recommended

PostGIS 2.0

  • Debian 6.0 (squeeze) - uses PostgreSQL 8.4

  • FreeBSD 9.1/PCBSD 9.1 - with PostgreSQL 9.2
  • Ubuntu 10.04 LTS (lucid) - uses PostgreSQL 8.4

PostGIS 1.5

  • Ubuntu 10.04 LTS (lucid) - uses PostgreSQL 8.4

PostGIS 1.4

Older guides

See also