Opened 6 years ago

Closed 4 years ago

#2358 closed defect (fixed)

Add post-check phase to PostGIS build (installcheck)

Reported by: robe Owned by: robe
Priority: high Milestone: PostGIS 2.2.0
Component: build/upgrade/install Version: 2.0.x
Keywords: Cc:

Description (last modified by robe)

Right now we are probalby the only extension that does our check before install. This is great because it allows you to do a quick check before you screw up your postgresql system, but is bad because there is no way verify the install actually works and will install all the necessary plumbing. It also means we have no way of verifying CREATE EXTENSION or even doing a true check of upgrade.

I propose a post-check option to solve this that is a check done after install. Since it is done after install it has a couple of benefits

  1. It can be run with CREATE EXTENSION thus testing our extension building
  1. We can easily squeeze in a true upgrade test in here since our model allows for installing multiple versions of postgis in the same instance.

So a switch something like --with-upgrade-from=2.0.4SVN

Will in post-check phase do a:

CREATE EXTENSION postgis VERSION "2.0.4SVN";
ALTER EXTENSION postgis UPDATE TO "2.1.0";

Since both winnie and debbie are doing make installs (have to double-check on debbie, but winnie definitely is), they'll be able to take advantage of this new flag to do a true upgrade regression test.

Change History (9)

comment:1 Changed 6 years ago by robe

Description: modified (diff)

comment:2 Changed 6 years ago by strk

For simplicity, I suggest we embed support for this to the existing run_test.pl, with a special switch.

comment:3 Changed 6 years ago by robe

works for me.

comment:4 Changed 6 years ago by robe

Summary: Add post-check phase to PostGIS buildAdd post-check phase to PostGIS build (installcheck)

comment:5 Changed 4 years ago by strk

run_test.pl is already able to perform post-install check via the --extension switch. Do we want to also test for script-based post-install checks ?

comment:6 Changed 4 years ago by strk

r13475 adds a simple "installcheck" that runs all regression tests after an extension-based install. It already serves the purpose of exposing some issues to be cleaned up.

Regina: I'll let you decide if you want to keep this ticket open or close it and file others for single issues that arise or enhancement that you want to add (like testing upgrades).

comment:7 Changed 4 years ago by strk

And as of r13480, "make installcheck" passes for me (includes SFCGAL, see #2316, #2778)

comment:8 Changed 4 years ago by strk

Owner: changed from strk to robe

comment:9 Changed 4 years ago by robe

Resolution: fixed
Status: newclosed

I'll close and file separately if needed.

Note: See TracTickets for help on using tickets.