Opened 8 years ago

Closed 7 years ago

#1161 closed defect (fixed)

move gserialized_gist to libpgcommon

Reported by: bnordgren Owned by: pramsey
Priority: medium Milestone: PostGIS 2.0.0
Component: postgis Version: 1.5.X
Keywords: Cc:

Description

I was getting a missing symbol error when attempting to run the raster regressions. lwgeom_pg.c uses utility functions from gserialized_gist.

Also, gserialized_gist uses utility functions from gserialized_gist_nd. The required functions have also been moved to gserialized_gist.

The attached patch applies to r7757, although you may have to manually remove postgis/gserialized_gist.c. Again the problem appears to be the $Id$ string.

Attachments (2)

gserialized_gist.patch (27.3 KB) - added by bnordgren 8 years ago.
Applies against r7757
gidx_to_string.patch (2.3 KB) - added by bnordgren 7 years ago.
Applies against r7784

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by bnordgren

Attachment: gserialized_gist.patch added

Applies against r7757

comment:1 Changed 7 years ago by strk

Resolution: fixed
Status: newclosed

Fixing the circular dependency sounds like the solution to the linking puzzle. Committed in r7768 togheter with a reordering of libpgcommon/liblwgeom items in linking lists and cleanups of duplicated symbols in raster module (pg)

comment:2 Changed 7 years ago by bnordgren

Resolution: fixed
Status: closedreopened

I believe dustymugs' complaint on the list is related to this ticket, as the gidx stuff seems to be supporting things in this general area. His unresolved symbol only occurs when the build is configured with --with-raster --enable-debug. The symbol in question is gidx_to_string.

Changed 7 years ago by bnordgren

Attachment: gidx_to_string.patch added

Applies against r7784

comment:3 Changed 7 years ago by bnordgren

attachment:gidx_to_string.patch should fix the missing symbol issue that dustymugs was having when specifying --enable-debug.

comment:4 Changed 7 years ago by Bborie Park

Resolution: fixed
Status: reopenedclosed

Patch gidx_to_string.patch committed in r7786

Note: See TracTickets for help on using tickets.