Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#988 closed defect (fixed)

chroot build method: autologin failure due to rasdaman

Reported by: kalxas Owned by: kalxas
Priority: critical Milestone: OSGeoLive6.0RC1
Component: OSGeoLive Keywords: 6.0
Cc: live-demo@…

Description

This issue happens when build_chroot script is used with live session username set to "user". The created iso refuses to autologin. This has been tracked with debug script so far and limited down to 3 packages (liblas, rasdaman and mb-system). When initrd modifications are not used this issue is not present.

Proposed solutions:

  1. Create the iso first without initrd customization and then use the created image file to run a second customization.
  2. Keep building with debug chroot scripts until we track down the package causing this.

Any other ideas I am missing?

Change history (8)

comment:1 Changed 7 years ago by kalxas

Owner: changed from live-demo@… to kalxas
Status: newassigned

using chroot debug script there was success to have an iso working: http://aiolos.survey.ntua.gr/gisvm/dev/osgeo-live-debug-build8833.iso without the above 3 applications and without docs and data installed

comment:2 Changed 7 years ago by kalxas

Priority: blockercritical
Summary: chroot build method: autologin failurechroot build method: autologin failure due to rasdaman

This is now more clear, the package responsible for this is rasdaman. After removing it from beta9, the autologin feature is now working.

I assume that there is some file issue that is placed in /home/user and then fails to move to /etc/skel during iso build.

We have to review this installer very carefully.

comment:4 Changed 7 years ago by hamish

hopefully fixed in >= r8884

('user' was owning files outside of /home/user)

Hamish

comment:5 Changed 7 years ago by hamish

it can't just be due to 'user' was owning files outside of /home/user, in 6.0beta9 if you run:

sudo su
cd /
find / -uid 1000

('user' is UID 999 in the live-iso)

you get 14000 files! including /usr, /var, and /etc/ld.so.conf.d/

/opt/gvSIG, Kosmo, qgis_mapserver, /usr/local/share/gisvm (!), web2py, and geonetwork seem to be the major offenders. probably because they extract tarballs to / as the superuser without using the --no-same-owner flag to reset the owner to root. (if so, it's an easy fix)

Hamish

comment:6 Changed 7 years ago by kalxas

Autologin now fixed and confirmed in build 8923. I propose to close this issue and open a new one for the permissions, since it is not only for rasdaman.

comment:7 Changed 7 years ago by kalxas

Resolution: fixed
Status: assignedclosed

Rasdaman demo working too

comment:8 in reply to:  6 Changed 7 years ago by hamish

Replying to kalxas:

I propose to close this issue and open a new one for the permissions, since it is not only for rasdaman.

continued in #994.

Note: See TracTickets for help on using tickets.