Opened 7 years ago

Closed 7 years ago

#989 closed task (fixed)

bury the "install" button a bit deeper to avoid accidental hard drive reformats

Reported by: hamish Owned by: live-demo@…
Priority: major Milestone: OSGeoLive6.0Final
Component: OSGeoLive Keywords: 6.0
Cc:

Description (last modified by hamish)

Hi,

it worries me a bit that a new user will pick up the DVD and click past the warnings that install ubuntu will reformat your hard drive. great way to lose a customer.

the default 'chroot method' puts this in your face a bit more, so we might consider making the autoboot just offer the "Try ${RELEASE}" button, and leave the "Install ${RELEASE}" to the documented desktop icon or elsewhere.

it seems the file to hack is /usr/share/ubiquity/gtk/stepLanguage.ui

maybe we can just remove the GtkButton? <child> object for "install_ubuntu" on lines 88-108 and the image object for ubuntu_installed.png on lines 75-87? (hopefully the widget packing of the rest adapts well)

better yet, figure how to bypass ubiquity at boot time all together, but still have it work if the user installs from the menu. maybe just edit /etc/init/ubiquity.conf and comment out the "starton" lines at the top?

Hamish

Change history (10)

comment:1 Changed 7 years ago by hamish

Description: modified (diff)

comment:2 Changed 7 years ago by camerons

Good idea, although I suggest not changing the login process too much for the current 6.0 release, as I'd prefer not to be changing our OSGeoLive quickstart docs so close to release: http://live.osgeo.org/en/quickstart/osgeolive_quickstart.html

comment:3 in reply to:  description Changed 7 years ago by hamish

Replying to hamish:

better yet, figure how to bypass ubiquity at boot time all together, but still have it work if the user installs from the menu. maybe just edit /etc/init/ubiquity.conf and comment out the "starton" lines at the top?

experimental attempt made in r8874, but it make make casper pack a sad & refuse to boot. time will tell....

Hamish

comment:4 Changed 7 years ago by kalxas

Personally I don't find this to be an issue, since all ubuntu live disks work like this, so I expect users to by familiar with this at some level. We already offered this option to the user in ISOLINUX loader in the past, it just moved to ubiquity. It is good to give an option to the user to start installing without going to the Desktop.

comment:5 Changed 7 years ago by kalxas

another thing: reformat is not happening by default, as the installer will provide a solution to fit ubuntu in current partition table

comment:6 Changed 7 years ago by micha

I tend to agree with Hamish here. Many OSGeo LiveDVD users will be used to Windows where you usually put in a disk, start some Setup, and click Next->Next without reading anything of course ;-), until it "goes away". Better to expect users who actually do want to install to go thru a few steps to find the button, rather than to risk some surprises for that one hasty user.

comment:7 in reply to:  5 Changed 7 years ago by hamish

Replying to kalxas:

another thing: reformat is not happening by default, as the installer will provide a solution to fit ubuntu in current partition table

well, anecdotally, since 12.04 came out I've had someone (rather intelligent) show up in my office because they knew I knew something about Linux, and after installing ubuntu themselves they couldn't find their C: drive anymore. ... and unfortunately for them it wasn't just a re-run grub issue: they'd wiped the disk. on the plus side I now know a bit more about ntfs partition recovery & salvage than I used to.

2c, Hamish

comment:8 in reply to:  4 Changed 7 years ago by hamish

Replying to kalxas:

Personally I don't find this to be an issue, since all ubuntu live disks work like this,

yes, but most ubuntu live discs are primarily installers, with a handy try-before-you-buy feature. Ours is primarily an instant OS, for us the installer feature is just an optional extra, and may of our users will never have used Ubuntu or a live OS disc before.

Hamish

comment:9 Changed 7 years ago by kalxas

fixed in rev [8874] and confirmed on build8877

comment:10 Changed 7 years ago by kalxas

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.