Opened 6 years ago

Closed 6 years ago

#1158 closed defect (fixed)

Cartaro uninstalls postgis.

Reported by: kalxas Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive7.0
Component: OSGeoLive Keywords:
Cc:

Description

I guess this has to do with the Cartaro ppa.

Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  liburiparser1 libfltk-gl1.3 libmuparser0debian1 libsvg-cairo libfltk1.3
  libopencv-core2.3 libspatialindex1 qgis-providers-common libopencv-ml2.3
  libkml0 libgsl0ldbl libsvg
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  cgi-mapserver gdal-bin grass grass-core grass-gui libgdal1-1.9.0-grass
  libgdal1h libmapserver libosgearth1 libotb libotb3.18 libqgis1.8.0
  mapserver-bin maptiler monteverdi osgearth otb-bin otb-bin-common otb-bin-qt
  php5-mapscript postgis postgresql-9.1-postgis-2.0 python-gdal
  python-mapscript python-qgis python-qgis-common qgis qgis-mapserver
  qgis-plugin-grass qgis-providers
The following NEW packages will be installed:
  libgdal1 php5-gdal
0 upgraded, 2 newly installed, 30 to remove and 2 not upgraded.
Need to get 4842 kB of archives.
After this operation, 214 MB disk space will be freed.
Get:1 http://www.geops.de/apt/ precise/main php5-gdal i386 0.1.3-0ubuntu1 [34.9 kB]
Get:2 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ precise/main libgdal1 i386 1.9.2-2~precise4 [4807 kB]
Fetched 4842 kB in 3s (1349 kB/s)

Change history (9)

comment:1 Changed 6 years ago by phaf

That is quite confusing. I will add --no-remove to the apt-get install command and check why this happens. The package from our ppa has only two dependencies and those are not related to PostGIS...

comment:2 Changed 6 years ago by phaf

Added in r10357 - will do further checks.

comment:3 Changed 6 years ago by phaf

The problem was the installation of 'libgdal1' from the Ubuntu GIS ppa, not of our package 'php5-gdal' which depends on the gdal lib. Grass uses its own libgdal, "libgdal1-1.9.0-grass" and can not be installed together with 'libgdal1'. Therefore I removed the installation of libgdal1 by our installer in r10358 and also use the grass version of libgdal1 I think this should solve this problem.

comment:4 Changed 6 years ago by kalxas

According to the new UbuntuGIS updates, we must use libgdal1h instead of libgdal1 which points to the 1.9 version.

comment:5 Changed 6 years ago by kalxas

Priority: criticalnormal

The situation is now better in build 10357. I will keep this open until I test the last commits in a few hours.

comment:6 in reply to:  3 Changed 6 years ago by hamish

Replying to phaf:

Grass uses its own libgdal, "libgdal1-1.9.0-grass" and can not be installed together with 'libgdal1'.

libgdal1-1.9.0-grass are the gdal grass data format plugins, which do not come with the main libgdal since they contain GPL code. They are two shared .so libraries which live in /usr/lib/gdal${VER}plugins/. I don't see the case where these could conflict with any other packages, they should be ok stand-alone.

Anyway, I wouldn't get too worried about these conflicts until the ubuntugis package transition & rebuilds are all complete and uploaded.

regards, Hamish

comment:7 Changed 6 years ago by jlarouche

Currently the libgdal1-1.9.0-grass is built from gdal 1.10.0, I simply forgot to change the package name when I uploaded it. It'll will be fixed tomorrow.

comment:8 Changed 6 years ago by phaf

As the problem still occurs in the latest builds, I disabled the installation of our additional package until the issues with the libgdal package are fixed.

comment:9 Changed 6 years ago by kalxas

Resolution: fixed
Status: newclosed

The problem is solved, thanks

Note: See TracTickets for help on using tickets.