Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1157 closed defect (fixed)

pgrouting fails to install after postgis update

Reported by: kalxas Owned by: dkastl
Priority: critical Milestone: OSGeoLive7.0
Component: OSGeoLive Keywords:
Cc: live-demo@…

Description

From logs (build10344):

===============================================================
install_pgrouting.sh
===============================================================
gpg: keyring `/tmp/tmpHDcaw_/secring.gpg' created
gpg: keyring `/tmp/tmpHDcaw_/pubring.gpg' created
gpg: requesting key B65ADE33 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpHDcaw_/trustdb.gpg: trustdb created
gpg: key B65ADE33: public key "Launchpad PPA for Georepublic" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
E: Unable to correct problems, you have held broken packages.
ERROR: pgRouting Package install failed! Aborting.

Change history (8)

comment:1 Changed 6 years ago by hamish

Hi,

perhaps the trouble is actually in the preceding installer?

Hamish

comment:2 Changed 6 years ago by kalxas

All projects that pull postgresql-9.1-postgis must switch to postgresql-9.1-postgis-2.0 according to #1154

comment:3 Changed 6 years ago by dkastl

Owner: changed from live-demo@… to dkastl
Status: newassigned

I'm aware of this issue with the changed package name of PostGIS. It's an unfortunate situation, because it seems to me that the stable UbuntuGIS PPA provides postgresql-9.1-postgis and unstable PPA postgresql-9.1-postgis-2.0

Furthermore the support for postgresql-9.1-postgis-2.0 was not complete in unstable PPA for all recent Ubuntu releases ... until yesterday (I just checked).

So now at least I can build new packages based on "unstable" PPA (which I got already warned on the UbuntuGIS ML is unstable and may break anytime ;-)

comment:4 Changed 6 years ago by kalxas

Cc: live-demo@… added

Yes, this situation is causing various problems during last week

I still do not have a successful build since alpha3... :)

comment:5 Changed 6 years ago by dkastl

Yes, when I updated to the new package to test and build, first I got QGIS uninstalled.

So why do we have to use unstable PPA? I know, that in the past we had to use it, because stable PPA did not really provide exciting packages. But now it looks much better and "stable" would be a lot better to avoid troubles like this one.

Any reason not to use "stable" PPA?

comment:6 Changed 6 years ago by kalxas

This is a good subject for tonight's weekly meeting on IRC. I support the idea of OSGeoLive being based on UbuntuGIS stable.

comment:7 Changed 6 years ago by dkastl

Resolution: fixed
Status: assignedclosed

A new pgRouting version (v2.0.0-rc1) has been released, which might be the final version for OSGeo Live 7.0

So I created new Ubuntu packages, which accept either the old or the new PostGIS package name as dependency, which should solve this issue.

Let's see with the next build if everything install again.

comment:8 Changed 6 years ago by kalxas

confirmed. pgRouting is included in build 10382.

Note: See TracTickets for help on using tickets.