Ticket #82 (closed defect: fixed)

Opened 5 years ago

Last modified 2 years ago

grass would not start

Reported by: timmie Owned by: osgeo4w-dev@…
Priority: major Component: Installer
Version: Keywords: grass
Cc: grass-dev@…

Description

see attached

Attachments

bug_grass-osgeo4w.jpg Download (33.7 KB) - added by timmie 5 years ago.

Change History

Changed 5 years ago by timmie

  Changed 5 years ago by neteler

  • component changed from Documentation to Installer

See also  http://trac.osgeo.org/grass/ticket/570

Please specify the Windows version

  Changed 5 years ago by timmie

Using Windows XP.

  Changed 5 years ago by timmie

* Windows XP * Python is already installed (PythonXY)

  Changed 5 years ago by hamish

  • keywords grass added
  • status changed from new to closed
  • resolution set to fixed

In GRASS bug # 570, timmie wrote:

I got it fixed on my computer. It was a problem with the win32 packages for python.

After copying them over from c:\Programme\pythonxy\python\Lib\site-packages\win32\ c:\Programme\pythonxy\python\Lib\site-packages\win32com\ c:\Programme\pythonxy\python\Lib\site-packages\win32comext\

    everything works.

The GUI is really nice and fast. congratulations to thos who made it.

  Changed 5 years ago by timmie

For testing resons I have both installed: OSGEO4W & GRASS standalone.

After the changes described in GRASS#570 the standalon wxpython launches.

The issue still persists with the OSGEO4W Grass.

GRASS is somehow interfering with my Python installation. This should not be as people may have many python installations on their system: E.g. Think of a QGIS plugin developer who wants to test the plugins for python versions 2.4, 2.5, 3000

Regards.

  Changed 5 years ago by timmie

Please update the pywin32 packages: startup problem with standalone winGRASS install and custom python -  http://trac.osgeo.org/grass/ticket/570#comment:38

  Changed 5 years ago by timmie

May I get a comment from the Python packager? Highly appreciated.

Thanks in advance.

follow-ups: ↓ 9 ↓ 12   Changed 5 years ago by warmerdam

Timmie,

Could you briefly describe the issue for me? I tried reading grass ticket 570 but rather got lost. When you speak of the "pywin32 package" do you mean the "python-win32" package or "python" package? I do not know who packaged python-win32, or what it does. Unfortunately the python-win32 packager did not include information in the http://trac.osgeo.org/osgeo4w/wiki/PackageListing list, so it is very hard to figure out what the history is.

Also, should this ticket be reopened if the problem is not yet resolved?

in reply to: ↑ 8   Changed 5 years ago by jef

Replying to warmerdam:

Could you briefly describe the issue for me? I tried reading grass ticket 570 but rather got lost. When you speak of the "pywin32 package" do you mean the "python-win32" package or "python" package? I do not know who packaged python-win32, or what it does. Unfortunately the python-win32 packager did not include information in the http://trac.osgeo.org/osgeo4w/wiki/PackageListing list, so it is very hard to figure out what the history is.

I plead guilty.

I installed it from  pywin32-212.win32-py2.5.exe into the OSGeo4W tree (after adding the python path to the registry) and tared it up as  python-win32-2.12.1-1.tar.bz2 and  python-win32-demos-2.12-1.tar.bz2

follow-up: ↓ 13   Changed 5 years ago by hamish

  • cc grass-dev@… added

grass devs interested in compiling against python or using pythonXY for WinGrass? may wish to have a look at this ticket.

  Changed 5 years ago by timmie

  • status changed from closed to reopened
  • resolution fixed deleted

in reply to: ↑ 8   Changed 5 years ago by timmie

Replying to warmerdam:

Timmie, When you speak of the "pywin32 package" do you mean the "python-win32" package or

Yes

Could you briefly describe the issue for me? I tried reading grass ticket 570 but rather got lost.

Summary: 1) issues discovered when running WinGRASS along with a already installed or later installed indepentant Python distribution. In particular PythonXY. 2) PythonXY was updated and is mostly upto date. 3) PythonXY developer states that his distribution is fine. 4) the issues occured at least at 3 installations 5) 2 workarounds were found.

Todo: 1) check this "python-win32" package. 2) try to package WINGRass in a way that is does not interfere with other Python installations.

Also, should this ticket be reopened if the problem is not yet resolved?

Did so.

in reply to: ↑ 10   Changed 5 years ago by timmie

Replying to hamish:

grass devs interested in compiling against python or using pythonXY for WinGrass? may wish to have a look at this ticket.

A small note: At least in my case I am not using PythonXY to * compile GRASS aginst * use it for GRASS

PythonXY is an all complete python distribution for windows that get's you started quickly with scientifc scripts. Comparable to Matlab (TM) We have to be very thankful to Pierre Raybaut for putting this together. THanks to Hamish to pringing this bug to the attention of all GRASS developers.

  Changed 5 years ago by timmie

Hello, this problem still exists on my Windows XP computer with latest Grass (WinGRASS-6.4.0SVN-r38959-1-Setup.exe).

The failure is definately not caused by PythonXY but by the way Python is included in the windows packages.

I tried to debug: 1) deinstalled GRASS 2) deinstalled PythonXY 3) installed latest GRASS => works fine. 4) installed offical Python 2.5 =>  http://www.python.org/ftp/python/2.5.4/python-2.5.4.msi 5) installed offical pywintypes =>  http://sourceforge.net/projects/pywin32/files/pywin32/Build%20214/pywin32-214.win32-py2.5.exe/download

6) tried to start GRASS => no success, same error message.

Thus, this bug is a blocker for all who have python installed besides a GRASS install on windows.

  Changed 2 years ago by neteler

  • status changed from reopened to closed
  • resolution set to fixed

Now Python2.7 has been packaged. Please reopen if the problem persists in a current GRASS 6.4.2 version.

Note: See TracTickets for help on using tickets.