Opened 9 years ago

Closed 9 years ago

#939 closed defect (fixed)

jdk version problems

Reported by: alucas Owned by: jng
Priority: high Milestone: 2.1
Component: Installer Version: 2.1.0
Severity: minor Keywords: java installer
Cc: External ID:

Description

Hello,

I found problems installing the unofficial 2.1.0 with java configuration. If the user is running jdk 1.6.0_12 (currently the latest version), when the installation ends tomcat service will not start.

From tomcat log:

[2009-03-27 23:53:56] [174 javajni.c] [error] the specified module could not be found. [2009-03-27 23:53:56] [986 prunsrv.c] [error] Failed creating java [2009-03-27 23:53:56] [1260 prunsrv.c] [error] ServiceStart? returned 1

It seems there is a problem with msvcr71.dll, I found two workarounds:

1) copy msvcr71.dll into tomcat bin directory. 2) Downgrade to jdk 1.5.0_xx

I suppose that the correct way is to include this assembly into the installer.

Thanks.

Change History (7)

comment:1 Changed 9 years ago by jng

Owner: set to jng

comment:2 Changed 9 years ago by jbirch

I don't really relish bundling another version of the c++ redistributable with the installer, and I'm pretty sure that we can't just distribute the single file. I think that we may need to require Java 1.5 at this point, same as we're requiring "ancient" versions of PHP / Apache.

alucas, could you please give this temporary, unpublished version of the installer a try?

MapGuideOpenSource-2.1.0-Unofficial-b.exe

I compiled it against the latest 1.5 JDK, and it appears to work OK on my PC after manually installing the Tomcat service. I've added another ticket (#953) for modifying the installer to install the Tomcat service.

comment:3 in reply to:  2 Changed 9 years ago by alucas

Replying to jbirch:

I don't really relish bundling another version of the c++ redistributable with the installer, and I'm pretty sure that we can't just distribute the single file. I think that we may need to require Java 1.5 at this point, same as we're requiring "ancient" versions of PHP / Apache.

alucas, could you please give this temporary, unpublished version of the installer a try?

MapGuideOpenSource-2.1.0-Unofficial-b.exe

I compiled it against the latest 1.5 JDK, and it appears to work OK on my PC after manually installing the Tomcat service. I've added another ticket (#953) for modifying the installer to install the Tomcat service.

Could anyone try to install the previous installer with jdk 6 update 12? After uninstall all my jdk's and jre's try to install a clean jdk 1.6 u12 and seems that the installer works. I'm not sure if it could be my jdk's installation.

comment:4 Changed 9 years ago by jng

I think this has to do with the jdk version used to build the Java API. Ideally a 1.5 JDK should be used since that should produce bytecode that is forward-compatible to 1.6

comment:5 Changed 9 years ago by jbirch

The version currently posted

http://download.osgeo.org/mapguide/testing/

as MapGuideOpenSource?-2.1.0-Unofficial-c.exe was built with the 1.5 JDK.

There have been a lot of changes though, and i haven't tested against Tomcat recently.

comment:6 in reply to:  5 Changed 9 years ago by alucas

Replying to jbirch:

The version currently posted

http://download.osgeo.org/mapguide/testing/

as MapGuideOpenSource?-2.1.0-Unofficial-c.exe was built with the 1.5 JDK.

There have been a lot of changes though, and i haven't tested against Tomcat recently.

Hi Jason,

The last installer works fine even with jdk 1.5 and 1.6. In anycase, it would be nice to include as a requeriment jdk 1.5 in the installer doc.

Maybe, we can close now the ticket.

comment:7 Changed 9 years ago by jbirch

Resolution: fixed
Status: newclosed

Closing. I think we'll have to add a windows build/install nodes page to capture requirements and what we could be doing better with the installer next time around.

Note: See TracTickets for help on using tickets.