Opened 10 years ago

Closed 10 years ago

#794 closed defect (fixed)

Connection to WMS server crashes server with 3 concurrent users

Reported by: trevorwekel Owned by: trevorwekel
Priority: high Milestone: 2.1
Component: Mapping Service Version: 2.0.1
Severity: major Keywords:
Cc: External ID: 1138613, 1138613.02

Description

With only three concurrent users the Server stops working after about 20 minutes of continuous use. Leading up to the crash, the server log file contains the following error messages:

  • "failed to stylize layer XXXX"
  • "Bad allocation"
  • "Out of Memory Exception"
  • "An Unclassified exception occured"

Change History (8)

comment:1 Changed 10 years ago by trevorwekel

Status: newassigned

comment:2 Changed 10 years ago by trevorwekel

  • Fix memory leak in GridData.cpp
  • Improve error message propagation from Fdo
  • Clip raster request extent to the spatial context extent of the underlying feature source

Submitted to 2.0.x branch under http://trac.osgeo.org/mapguide/changeset/3515

comment:3 Changed 10 years ago by franciscorojas

Milestone: 2.1
Priority: mediumhigh

The same defect occurs on MGOS 2.0.2 , and MGE 2009 with or without SP1, this defect must be fixed by now and for MGOS 2.1.

comment:4 Changed 10 years ago by tomfukushima

We found that this problem occurs when there are a large number of resources in the repository. The web tier does an EnumerateResources? for every GetMap? operation. We are currently looking into a solution for 2.1.

Can you tell me about how many resources (maps, layouts, feature sources, etc.) that your repository has?

Tom

comment:5 Changed 10 years ago by trevorwekel

Component: WMS InterfaceMapping Service

Please note - this defect relates to WMS consumption from other WMS servers. I should have been more explicit with the defect description. Serving WMS from MapGuide is different functionality.

This defect is easily reproducible by pulling a layer from any public WMS server. Typical memory leaks are in the 1MB per request range. The MapGuide server will quickly run out of memory.

I have changed the component to more appropriately reflect the defect area. The unclassified exceptions are typically due to inadequate propagation of error messages from the external WMS server. This has also been corrected with the code submission.

comment:6 Changed 10 years ago by franciscorojas

There is an updated information for the WMS Issue, I have 220 Resources on the repository , and two WMS Feature Source and 6 raster layers that comes from the WMS FeatureServices?, one comes from an Internal WMS Server based on OAS and MapViewer? and the other one comes from a third party WMS from Digital Globe.

So the memory leak decrease the performance then Raster Images gone, and finally nothing is displayed on the map.

The issue is related to MGOS 2.x including 2.0.1,2.0.2, MGE 2009 and MGE 2009 Update 1.

Do you think that for MGOS 2.0.x will be a Binary Hotfix, instead of recompile everything including the updated code submited by trevorwekel.

comment:7 Changed 10 years ago by trevorwekel

External ID: 11386131138613, 1138613.02

comment:8 Changed 10 years ago by trevorwekel

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.