Opened 10 years ago

Closed 10 years ago

#614 closed defect (fixed)

Selection against a joined feature source returns an extra feature

Reported by: mgluobin Owned by: brucedechant
Priority: high Milestone: 2.1
Component: General Version: 2.0.1
Severity: blocker Keywords:
Cc: brucedechant External ID:

Description

Compiling the source code from SVN trunk vesion, when doing selection against a joined feature source the 1st feature is always returned regardless of filter along with the expected results.

Change History (11)

comment:1 Changed 10 years ago by mgluobin

Component: GeneralServer
Severity: trivialblocker

using a server trunk build (3247) on windows xp, when doing querying against a joined feature in ajaxviewer , the 1st feature is always returned regardless of filter along with the expected results.

comment:2 Changed 10 years ago by mgluobin

Component: ServerGeneral

comment:3 Changed 10 years ago by tomfukushima

Cc: brucedechant added

comment:4 Changed 10 years ago by brucedechant

What feature sources are you joining? What is the primary and what is the secondary? (Example: Primary=SDF Secondary=Access)

What kind of join are you doing? Inner? Outer? 1-1? 1-Many?

What does your filter look like that exhibts this issue?

comment:5 in reply to:  4 Changed 10 years ago by mgluobin

When i use the task of query in the ajaxviewer, the query result exhibts this issue. And only the attribute data of the 1st feature in query result can be listed in the attribute panel,the others can not be listed.

I use the data:

Primary=Shp Secondary= Access or mysql <RelateType?>LeftOuter?</RelateType?> <ForceOneToOne?>false</ForceOneToOne?>

comment:6 Changed 10 years ago by brucedechant

I cannot reproduce this with a SHP to Access join using the current trunk code. (My dataset was just sample world countries)

I used the following filter on the layer: (Key is from the primary feature source) Key >= 'CA'

It only returned Macedonia and nothing else when I entered "AC" into the query.

Can you provide the filter you are using that causes this issue?

comment:7 Changed 10 years ago by brucedechant

I need to clarify that the query I specify for the search task is: Name LIKE '%$USER_VARIABLE%'

Which is a different attribute then what the layer filter uses.

comment:8 in reply to:  7 Changed 10 years ago by mgluobin

I used the filter: FeatId? < -99999

The return result: [{"displayValue":1,"centerX":536380.15323754,"centerY":4337727.8276862,"idList":{"FeatId?":1}}]

In fact, any filter can cause this issue using the task of query in the ajaxviewer.

comment:9 Changed 10 years ago by mgluobin

Only a joined feature sources can cause this issue.

comment:10 Changed 10 years ago by brucedechant

Owner: set to brucedechant
Status: newassigned

I was able to replicate this.

comment:11 Changed 10 years ago by brucedechant

Resolution: fixed
Status: assignedclosed

See submission revision 3524.

Note: See TracTickets for help on using tickets.