Opened 10 years ago

Closed 10 years ago

#593 closed defect (fixed)

Incorrect selection behaviour when disabling properties pane

Reported by: isca Owned by:
Priority: medium Milestone: 2.1
Component: AJAX Viewer Version: 2.0.1
Severity: major Keywords: AJAX, properties pane, selection
Cc: External ID:

Description

When disabling the properties pane in the AJAX viewer in MapGuide Studio, selecting features behaves incorrectly.

To reproduce:

  • Create a weblayout with properties pane disabled
  • Select point or linefeature (most visible on high zoom level)

Result:

  • Incorrect feature is selected

It seems to be the map is shifted against the real coordinates.

The problem is also visible when trying to select a polygon near its boundaries. A polygon in the neighbourhood will be selected.

Change History (2)

comment:1 Changed 10 years ago by tomfukushima

Fixed by r3557. See ticket #826; looks like it is a duplicate of this one.

comment:2 Changed 10 years ago by tomfukushima

Milestone: 2.1
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.