Opened 11 years ago

Closed 11 years ago

#53 closed defect (fixed)

php viewer address/parcel search does not show pushpin symbols

Reported by: jng Owned by:
Priority: medium Milestone: 1.2
Component: Samples Version: 1.2.0
Severity: minor Keywords:
Cc: External ID: 926776

Description

The Parcel Search and Address Search functions in the 1.1 php viewer sample does not display the push pin symbols in the 1.2 beta.

This ticket was submitted based on the assumption the 1.1 viewer samples should work on the 1.2 beta as the current download site for the viewer samples says to use the 1.1 samples.

Steps to reproduce:

1) Download the 1.1 phpviewersample

2) Extract to the www direcotry in the MGOS web extensions directory

3) Open http://<mapguide site>/phpviewersample/ajaxviewersample.php

4) Open the "Find Parcels" task in the Task Bar.

5) Search for "SCHMITT" (another note: This is now case sensitive unlike before. Intended functionality?)

Expected: Push Pin symbols to be displayed for all the matching search results. Clicking on a particular result zooms to the position of the matching symbol.

Got: Nothing. However, clicking a particular search results still zooms to the position where the Push Pin symbol *should* be.

Attachments (1)

ParcelMarker.mgp (11.1 KB) - added by rexszeto 11 years ago.
Package containing a layer definition and a feature source

Download all attachments as: .zip

Change History (10)

comment:1 Changed 11 years ago by rexszeto

External ID: 926776

Changed 11 years ago by rexszeto

Attachment: ParcelMarker.mgp added

Package containing a layer definition and a feature source

comment:2 Changed 11 years ago by traianstanev

Owner: set to traianstanev

Looks like I'm to blame.

comment:3 Changed 11 years ago by traianstanev

Resolution: fixed
Status: newclosed

comment:4 Changed 11 years ago by jng

Resolution: fixed
Severity: majorcritical
Status: closedreopened

This problem still exists in 1.2 beta 2. Reopening ticket.

The same steps reproduce the same results as beta 1 did.

The pushpins are nowhere to be seen on the Sheboygan dataset.

comment:5 Changed 11 years ago by jng

Severity: criticalminor
Summary: 1.1 php viewer sample functionality broken in 1.2 beta (no pushpins)php viewer address/parcel search does not show pushpin symbols

Okay, I've tried the same php code from the viewer sample to place symbols in my other maps, and unlike the Sheboygan Dataset, it actually does place the points with symbol styling, where I wanted them to.

The problem at the moment looks like it's solely related to the Sheboygan Dataset.

comment:6 Changed 11 years ago by jng

Component: Web APISamples

comment:7 Changed 11 years ago by jng

Also this was tested on the new published Sheboygan Dataset that was updated to resolve ticket #42

comment:8 Changed 11 years ago by anonymous

Owner: traianstanev deleted
Status: reopenednew

The problem is that the coordinate system set in the temporary SDF file that holds the pushpins does not match the coordinate system of the Sheboygan map. The $ll84 variable in findparcelfunctions.php needs to be set to:

$ll84Wkt = 'GEOGCS["WGS84 Lat/Long?\'s, Degrees, -180 ==> +180",DATUM["D_WGS_1984",SPHEROID["World_Geodetic_System_of_1984",6378137,298.257222932867]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]]';

comment:9 Changed 11 years ago by tomfukushima

Resolution: fixed
Status: newclosed

Please retest with latest posted viewer samples, it has the correct findparcelfunctions.php file.

Note: See TracTickets for help on using tickets.